Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When I press the Email link in the sharepoint site, Outlook is getting opened normally but the original site URL is getting changed to mailto:xxxxxx@xxxx.com and the message "Internet Explorer cannot display the webpage" is getting displayed on the page in IE

share|improve this question
    
Are there some more (configuration) details? In which case do you mean? I have here the personal contact because of combination with Lync: no problem. In document library "E-mail a Link": no problem. In wild web page (no sharepoint): mailto: no problem. –  Shegit Brahm Aug 22 '12 at 6:44
    
The problem is only for me, might be some settings in IE8. How to know which setting to change? –  user9432 Aug 22 '12 at 6:50
    
I have no idea. But maybe you have a patient colleague where evereything works fine and go through step by step? If not, save your current setting (by screenshot etc) and try defaults? –  Shegit Brahm Aug 22 '12 at 6:54

1 Answer 1

up vote 0 down vote accepted

Ie8 has a problem with the links being to long, links less than 512 characters would work fine!

You can see the link by going to F12 develooper or Ie developer Tools and click on the mouse curser, then click on the url link.... you should be able to see the link like so:

<a id="Help" href="mailto:thisisanemail@domain.com">Hi click to email me</a>

for more info look here:

http://stackoverflow.com/questions/2241274/mailto-fails-in-ie-where-there-is-a-long-body-text-is-there-any-way-to-resolve

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.