Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am having when Exporting large lists to excel (over 14K records). It displays “Running security Scan” at the bottom of the screen and then gives “An unexpected error has occurred. Changes to your data cannot be saved” in Excel (data does not load).

I am using IE 9 and MCAffee AV on the client side.
Sharepoint Version is 2010 Foundation

Not sure whether the issue is related to the AV however. Could it be some timeout setting that I need to modify? Maybe a setting in Sharepoint?


share|improve this question

3 Answers 3

Here is a trick I've tried in your situation:

  1. Change your view in SharePoint to only display like Maximum 1000 rows. (use the Limit in the bottom of the view definition screen)
  2. Attempt again to export to Excel - this should work without issues (if it doesn't the problem lies elsewhere in your SharePoint and then you should have a look in ULS)
  3. Change back the View to show all items or those you need.
  4. Use the Refresh All in Excel to get latest updates from your View
share|improve this answer
Thanks - it is a good workaround (but not really a solution) +1 –  Joseph Caruana Aug 21 '12 at 9:32
It might actually not exist a proper solution for that amount of data. I've search for alternatives myself at the time, besides you only need to do the trick once per list, then Excel would be able to work properly. You cannot rely on Excel services neither as you have SPF. –  C. Marius - MVP Aug 21 '12 at 10:48
Thanks for your reply. Yes, it could do since it only needs to be done once. I will do some other research myself and let you know the outcome. –  Joseph Caruana Aug 21 '12 at 11:01
Tried this approach but excel still gave the same error –  Joseph Caruana Aug 21 '12 at 12:28

Had the same problem with two user fields containing texts. Export works fine without them.

And the Solution was to add additional Filter to the View! The Filter is on Date Created Field (in my case) > xx and it's set so that all the data that we were displaying before is also shown, the additional Filter does not return any less Results, so the amount of data is the same, but this fixed the issue and the two user fields can normally be in the View. Weird... I guess the problem is in the query, and with an additional Filter we can limit the query a bit more?

Try it out, should work..

share|improve this answer

It turned out to be related to user fields and not to the size of the data. I removed 2 user fields and added 7 other fields (to confirm that it is not related to the size of the data). & it worked. Somehow excel seems to have problems with exporting a large amount of user fields.
Thanks everyone for your useful support.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.