Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have an immediate timer job that stopped working on the 7th July. It is the only timer job that has stopped and will not run.

I've restarted the services, set the job to run every 1 min, reset IIS. Even rebooted the app server.

Am I missing something simple? Should I delete and recreate the job, if so are there any pitfalls I should be wary of?

Thanks

share|improve this question
    
just to clarify, what do you mean by 'immediate' timer job? Normally I would associate that term with a one-off, or one-time job, but it seems you have yours set up as a 'scheduled' job. –  Paul Lucas Jul 30 '10 at 3:59
    
@profilesfrankodlive: Please only use the community wiki option when asking 'discussion style' questions. Otherwise no-one is able to gain reputation on your post. See sharepointoverflow.com/questions/432/… for more info. Thanks :-) –  Alex Angas Jul 31 '10 at 23:37
add comment

4 Answers 4

Make sure you restart the "Windows SharePoint Services Timer" service after reinstalling/reactivating your feature. If you're trying all of these intervals and none of them are working there's a good chance you haven't done this and your job is still attempting to run old code. If your job is set to run across multiple web front ends, you must also reset this service on the other web front ends.

Also, note that your timer job will wait until that interval to run the first time. If you create a job on an interval of 5 minutes and you activate it at 12:00 it won't run until 12:05. If you're running an immediate job and it's not firing, have you tried the execadmsvcjobs operation of STSADM?

share|improve this answer
add comment

Delete the timer job definition and start again. It may have a stale "running job" recorded in the Config database. If this is true, it will still show the job as running even when it is not.

share|improve this answer
add comment

I didn't, poor show on my part.

Event ID:5uuf

Log: The previous instance of the timer job 'Application Server Administration Service Timer Job', id '{35C862E7-5A24-4E8B-B463-842460B8824D}' for service '{422146C8-6289-4FC9-A3A1-0438B111DF5D}' is still running, so the current instance will be skipped. Consider increasing the interval between jobs.

The interval has been tried at 1, 15, 30 & 55 minutes. Still will not run.

The job id that I want to run is not the job id in the logs. I have noticed that the timer job was aborted at 02:20.

share|improve this answer
add comment

Did you check the ULS log for errors related to the timer job?

share|improve this answer
    
I didn't, poor show on my part. Event ID:5uuf Log: The previous instance of the timer job 'Application Server Administration Service Timer Job', id '{35C862E7-5A24-4E8B-B463-842460B8824D}' for service '{422146C8-6289-4FC9-A3A1-0438B111DF5D}' is still running, so the current instance will be skipped. Consider increasing the interval between jobs. The interval has been tried at 1, 15, 30 & 55 minutes. Still will not run. Thanks –  Frank O'Donnell Jul 29 '10 at 9:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.