Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Is there a way to hide (or remove) the search bar located above the 'Site Action' link and below the 'Welcome {User name}' for SharePoint 2007 web pages?

enter image description here

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

You have two options:

  • Remove the Delegate control SmallSearchInutBox from the master page
  • The "right" way: create/activate a feature with an empty Control element with that ID and a Sequence below 25.

You can find a feature like this at Remove the Search Box from SharePoint Sites

share|improve this answer
    
+1 for Delegate control - it's the way to go. –  Andy Burns Aug 17 '12 at 8:31
    
Are there other ways beside editing the master page as I still want some of my site to have search bar and plus I cannot access the master page due to restriction set by system administrator. –  Jack Aug 17 '12 at 8:38
    
That's the second option specified. The feature at the link has WebApplication scope, but that can be changed to as finegrained as you want. –  Per Jakobsen Aug 17 '12 at 8:52
    
then you can try the solution of hiding the control by setting/overriding the CSS class. You can add a content editor webpart and add the CSS in to the webpart, this WP can be added only in those pages where you want to hide the search control. –  Manju Aug 17 '12 at 9:23
add comment

All the controls and styling for the search bar will be in your master page, whichever one you are using. You can select the control and add a display:hidden css tag to the div and this will hide the control.

This method means the code for the search bar will be compiled so the page is not necessarily more lightweight, all it does is hide the control. If you actually want to remove the control completely, be careful of that because you may have trouble getting it back!

Tal

share|improve this answer
    
Please tell me more about how to select the control and add a display:hidden css tag. –  Jack Aug 17 '12 at 8:37
add comment

This is added in the master page, hence removing the delegate control present in the master page should sove your problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.