Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'd like to have SharePoint handle PDFs in such a way that PDFs will open in a browser, but will Edit in Acrobat. It seems that I can have one or the other:

If the DOCICON.xml is configured to show:

<Mapping Key="pdf" Value="pdficon_small.gif" OpenControl="AdobeAcrobat.OpenDocuments" />

No "Edit Document" or "Edit in Acrobat" menu appears, but I am able to view the PDF in a browser. However, if my mapping looks like this:

<Mapping Key="pdf" Value="pdficon_small.gif" OpenControl="SharePoint.OpenDocuments" />

I can edit in Acrobat beautifully, and it works with the drop-down menu per document, but it won't display the PDF in the browser, even after changing the settings in Acrobat/Reader to Edit -> Preferences -> Internet -> Display PDF in Browser but will show the popup of "Read Only" or "Edit" radio buttons.

I've also tried to fool with the client-side application, on the list and the site collection to open documents in browser by default. No change.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I did this by changing the entry in docicon.xml to

<Mapping Key="pdf" Value="pdficon_small.gif" OpenControl="SharePoint.OpenDocuments" />

And resetting IIS. How did I forget resetting IIS? Everything works now.

Also the other mapping setting doesn't work on those web applications using https so I had to use the SharePoint.OpenDocuments opencontrol.

share|improve this answer

You can try to see if a permssion issue. Change the permission of the headers from the browser.
Please, go to the Central Administration, then Manage Web Application.
Select the WebApp where you have the pdf files. Then Click on the Ribbon on General Settings, General Settings again.
In the PopUp, in the section Browser File Handling, click on Permissive. Click Ok and try again.
Cheers!

share|improve this answer
    
I've tried that. –  Mike Aug 16 '12 at 21:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.