SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got the following error

"There was an error encrypting or decrypting credentials. Either a credential update is currently being performed, or you must update the farm account credentials on this server before you can perform this task."

I tried running

stsadm –o updatefarmcredentials –userlogin username –password password

but both the command prompt and powershell gives above error. I have even tried changing passwords in services and IIS Manager but nothing worked.

share|improve this question

There is a WSS 3.0 hotfix for that. It's a known bug. It's the 3rd to last bullet.

share|improve this answer
Hi Mike, when I tried to run the hotfix, it says "There are no products affected by this package installed on this system" – shreyas Aug 13 '12 at 22:56
I got the solution. here it is – shreyas Aug 16 '12 at 18:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.