Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Everything was working perfectly and then one of my colleague made some changes and is on holidays now.

any site I create I get forbidden 403 error not sure why tho.

I looked at site permissions they look fine.

share|improve this question

4 Answers 4

up vote 3 down vote accepted

Are you creating subsites which shares the masterpage/page layouts from the root site collection? If yes, then see if the master page and layouts are checkedin/published and approved.

share|improve this answer
1  
I forgot to add permissions to web template folder in 12 hive –  Muhammad Raja Aug 13 '12 at 12:29

Verify which user is the app pool identity for the web application in which u r creating the site. If your friend's account is the app pool identity then change it to your account.

share|improve this answer
    
aspadvice.com/blogs/rjdudley/archive/2005/12/21/14422.aspx for more info... –  alam235 Aug 13 '12 at 11:57
1  
App pool accounts should not be set to run as an individual's account. You should create dedicated accounts. –  Mike Oryszak Aug 13 '12 at 12:27

try this out:

This is for people who get the following error either immediately after you create a WSS site, or when you try to access a WSS site or SPS portal:

You are not authorized to view this page

You do not have permission to view this directory or page using the credentials that you supplied.

Please try the following:

Contact the Web site administrator if you believe you should be able to view this directory or page. Click the Refresh button to try again with different credentials. HTTP Error 403 - Forbidden: Access is denied. Internet Information Services (IIS)


Technical Information (for support personnel)

Go to Microsoft Product Support Services and perform a title search for the words HTTP and 403. Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled About Security, Authentication, and About Custom Error Messages.

If you are using SPS, try to access http://<portalname>/default.aspx instead of http://<portalname>/. If you can access the URL with the pagename, then the problem may be in your application pool settings. Likewise, if you try to access a WSS site and get this error, see if you can add default.aspx to the URL. If that works, same problem. You might also get this error immediatelyt after you create a WSS site, at the point where you are supposed to pick the site template.

Fortunately, the fix is really easy. You need to open up the IIS manager on the server, and the open the properties for your virtual server. On the Home Directory tab, you probably need to change the Application Pool the site is running under. There's probably one named SpsAppPool or something like that. If there are several and you're unsure, try choosing them one by one, and trying to access the URL (the one without the default.aspx) after each change.

The application pools for the SharePoint site were modified from the default. So reset them, including the AppPools for _layouts, _vti_bin, and _wpresources. Their AppPools are now the default, and are the same.

share|improve this answer

You need to open up the IIS manager on the server, and the open the properties for your virtual server. On the Home Directory tab, you probably need to change the Application Pool the site is running under. There's probably one named SpsAppPool or something like that. If there are several and you're unsure, try choosing them one by one, and trying to access the URL (the one without the default.aspx) after each change.

share|improve this answer
3  
You should not randomly select App Pools until one works. If there is an App Pool for the given web app you can verify which one ad then resolve any open issues. –  Mike Oryszak Aug 13 '12 at 12:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.