Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am facing following warning message when i add list as webpart. "This view cannot be displayed because it exceeds the list view threshold (5000 items) enforced by the administrator."

Also when i directly go to the list and change the view it gives "Displaying only the newest results below. To view all results, narrow your query by adding a filter".

Any suggestions/pointers on this would be higly appreciated.

Regards, Ketan Gandhi

share|improve this question
add comment

2 Answers 2

Hi by default 'List View Threshold' is set to 5000, you need to change the setting if you need to show more than 5000 items. Please ask your administrator to increase the 'List View Threshold' value. Steps to reset the value :

  1. Open Central Administration
  2. Go to 'Manage Application' under 'Application Management'
  3. Choose the web application in which you want to make the changes (example : http:// yourserver:80)
  4. In the ribbon follow 'General Settings -> Resource Throttling' there you can find 'List View Threshold' is set to 5000, change the value you want
share|improve this answer
1  
@Diptarag...many thanks for your response, however it is not recommended to change the default threshold limit...Also my list contains more than 5000 item, however my "View" does not contain more than 5000 items. Also in case of second error" Displaying" it sometimes work for few views with this warning message and in few views it does not disply any items –  Ketan03 Aug 13 '12 at 9:18
    
yes that's a cmmon problem as ur view is nothing bt a query and that threshold applies to query also,evn if ur view return less than 5000 rows but ur query runs on a list which has more than 5000 items,you may try indexing the field on which you are creating the view,this may avoid the problem or you can temporarily disable the threshold,for more detail please visit these links [link]sharepoint.microsoft.com/blog/Pages/… & [link]sharepoint.microsoft.com/Blogs/GetThePoint/Lists/Posts/… –  Diptarag Aug 13 '12 at 9:49
    
@Diptarag..... i guess "Indexed Column" should hopefully resolve this issue? –  Ketan03 Aug 13 '12 at 10:34
    
@Ketan03 I think so, please try once and do let us know if it works –  Diptarag Aug 13 '12 at 12:40
add comment

Not Recommended. Create indexed column and create filter views of list.

share|improve this answer
    
Hi Shilabhadra, Welcome to SP.SE! While your answer is on the right track, it could be marked for deletion as it's very short and lacks details. Can you please edit your answer to elaborate the points points? –  Vardhaman Deshpande Nov 11 '13 at 11:37
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  John Chapman Nov 11 '13 at 14:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.