SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
  • i installed the RBS.msi.
    • my rbs tables are created in the sql sharepoint content database
    • and i performed the powershell commands.

im running SP2013 Foundation Preview with SQL Server 2008 R2 Express on 2008 R2 Server unfortunately i had troubles down- / and uploading documents on my SP-Server. I checked the log-files and saw that my rbs service did not have any EXECUTE permissions on some rbs databases. So i unattached my content DB from the RBS like this

$cdb=Get-SPContentDatabase <ContentDbName>




Afterwards i was able to upload documents again. Now that i have reattached my content database to the RBS i still can upload documents but the files are not stored inside of the rbs directory.. any ideas how to troubleshoot?

share|improve this question… was the same issue.. apparently a bug in the preview – Peter Sep 4 '12 at 15:08
Myself I've installed and configure RBS (correctly) in Sharepoint 2013 but doesn't work. It didn't put any file in File System (BLOB Storage). The rights seems to be ok. Any idea why? Other people seems to have the same issue:… Thanks Grig – user26968 May 20 '14 at 15:31
up vote 1 down vote accepted

Solved my issue.. i checked the user context which my sharepoint web application is running. i thought it was another user than it really was. so i checked the rights for this user on my DB... obviously there were none.. so i set them up and at least this error was solved.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.