Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have an InfoPath 2010 form that is published to a form library in SPS 2010 foundation and set to load in the thick client. When a user tries to open the form it prompts them for their user credentials specifically for the SharePoint web services which are used in the form, this still happens even if I give users farm admin and site collection admin rights. The only account that this doesn't happen on is the farm account.

share|improve this question

1 Answer 1

Form templates that contain business logic driven by managed code, access data from external resources, or use data connections that are managed by an administrator must be granted trust to execute code and access data

Besides sandboxing or administration-approval, try to add your sharepoint site to trsusted sites and Local Intranet in IE or ControlPanel menu Tools > Internet Options > Security > Trusted sites (Local intranet) > Add your sharepoint weapps using wild cards

The short NETBIOS names also should be enlisted

Fig.1.1. Adding Sharepoint Sites to Trusted sites in Internet options

Fig.1.1. Adding Sharepoint Sites to Trusted sites in Internet options

Fig.1.2. Adding Sharepoint Sites to Local Intranet sites in Internet options

Fig.1.2. Adding Sharepoint Sites to Local Intranet sites in Internet options

As a system administrator you probably want to apply this to all users

Login to DC through account with domain admin privileges and create a package with above settings

Control panel > Add or remove programs > Add/Remove Windows Components > Internet Explorer Enhanced Security Configuration > Uncheck the Internet Explorer Enhanced Security Configuration > Next, etc. to complete wizard

Start > All Programs > Administrative Tools > Active Directory Users and Computers > righ-click your domain name (or organizational unit to users of which you want to apply this) > Properties > "Group Policy" tab > New > enter name for the new Group Policy Object > selct it > click Edit button> User Configuration > Windows Components > Internet Explorer Maintenance > Security > Security Zones and Content Ratings > Import the current security zones and privacy settings > close all opened windows

Optional: Re-enable Internet Explorer Enhanced and Security Configuration < Add/Remove Windows Components

These changes can take time up to 60-90 min to propagate

I develop against my Office 365 (Sharepoint online) with built-in sandboxing of published Infopath form templates. Usually, I attribute Full Trust securitty level and digitally sign filler/client Infopath forms (on ribbon File > Info > Form Options > Security and Trust) even to launch them locally in Priview (F5) from Infopath Designer 2010 though this does not overcome the necessity to be administrator approved if they are launched from Sharepoint.

Fig.2. Attributing Full Trust in Infopath **Form Options**

Fig.2. Attributing Full Trust in Infopath Form Options

Otherwise, I cannot locally preview fresh empty (without any code behind) Infopath filler/client form getting:

  • Infopath cannot open a new form.
    The form template is not valid

    Show deatails:
    InfoPath cannot open the selected form because of an error in the form's code.

    Policy settings prevent opening Internet forms with managed code. To fix this problem, contact your system administrator.

though it is not internet form and it does not contain any code.

Policy settings prevent opening Internet forms with managed code

Fig.3. Policy settings prevent opening Internet forms with managed code.

It is weird, but Domain security level without signing is alwayes enough to open published to form library Inforpath form template from Sharepoint. At least, in y Sharepoint online site (Office 365).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.