SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been trying to get the value of a check box in a sp list. so, I have List[a] and List[b]. List[b] contains a check box which I am trying to get the value of inorder to put in in List[a].

I'm using Infopath 2010. I've tried doing this by using a ckbox in List[a] -- that did not work. Then tried to use a text box in List[a] to get the value -- that did not work.

Any help?


share|improve this question
"List[b] contains a check box"?! Really list contains data fields and list items (rows). Checkbox is visual control rendering Yes/No type of data field value in web page or IP form. There are many of them (either Yes/No values or checkboxes) in each of lists! Which of them from List[b] you want in an item of List[a] ? What is the relationship between 2 Yes/No data fields, or values sets, of 2 lists? – Gennady Vanin Геннадий Ванин Aug 3 '12 at 21:01
I'm pulling the list values through a data connection in infopath. the value is (yes/no) – ironman Aug 3 '12 at 21:08
This is the question! which of the values of a column (of checkboxes of List[b]) to put in one checkbox (or text box) of List[a] item? They are many to choose from and it is not clear how. They are already stored in List[b] – Gennady Vanin Геннадий Ванин Aug 4 '12 at 2:59
??? not sure I understand what you are saying.... there is a check box field that I have in list[b] the values are either yes or no. I'm trying to get that value and put it in list [a] ... "many to choose from " not sure what you are talking about.. there is only one field in the list that is a check box.... – ironman Aug 6 '12 at 14:59
From where do you want to get and use the value, from within InfoPath? – James Love Aug 6 '12 at 15:45
up vote 0 down vote accepted

I figured it out. I was choosing my field from the queryFields section instead of the dataFields section. This fixed the issue. Hope this helps someone else too.

remember to choose the field from the datFields Area

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.