Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have successfully created a contact list in SharePoint 2010 and linked it into outlook. It all seems to be working as it should except for one issue:

Creating a new contact entry that contains information in the 'website' field.

If I create the contact inside SharePoint and enter 'bob.com' in the website field (deleting the 'http://' bit), I get a message saying invalid URL when I try to add the contact. This is presumably because its type is set to hyperlink and it requires and 'http://' in front of it for some daft reason. That's annoying but fine.

However, when I add the contact from inside outlook including information in the website field without the 'http://', it will act like it accepts the contact but not actually add it. It gets put in the 'sync failures' folder. But most annoying it doesn't tell you.

Because of this I'm getting a whole bunch of shared contacts from people not ending up in the contact list because people don't know they entered a web address wrong.

How can I fix this issue?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

I am working on this issue (for the last 6 hours) right now. To resolve this, I went into Sharepoint and edited the fields for the Contact List. I deleted the field named "Web Page", which had a hyperlink datatype. I created a field call "Web Page" which is just a text field.

This appears to have fixed the issue and I am now getting my contacts to add to the shared list without failures. I will have to see if there are any issues caused by this, but so far it looks good.

Sharepoint

  1. Click on the contact list you have created...
  2. List item>List Tools>List>List
  3. List item>Settings> Click on the "Web Page" field & then delete it
  4. List item Create Column - > Name: Web Page - Type: Single Line of Text
share|improve this answer
    
That's probably the easiest answer I suppose. I'm assuming that the entered 'hyperlink' then isn't clickable? But at least contacts can then be entered by users properly. Any way to do it without deleting the field? As that will delete the data too no? –  Nicholas Aug 16 '12 at 22:26
add comment

Yes, it would delete data in the deleted column. You need to make sure you have a good local copy of the complete list. Once you have that, you can clear everything out of the shared list and then copy the good list into the shared/synced list.

I was not able to import a .csv file on Sharepoint for Office365, so you may need to rely on the Outlook Sync like I did. Make sure you have the Outlook logging off, as it will slow it down a lot, when you sync the shared list.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.