SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We've migrated a MOSS 2007 Site Collection into SP2010 as a Site Collection under a tenant in a multi-tenancy set up. This migrated SC gives an error on checkout through the UI that states that the user either doesn't have permission to check out the document or it is already checked out to another user (neither is true).

Checkout fails using the item's drop-down menu or the ribbon. Checkout also fails on this SC regardless of if the content was migrated or if it's new, and checkout fails in newly created Doc libs as well.

We can successfully check out multiple documents at once through the UI, and individual documents through the client application (Word, Excel, etc.). We can also successfully check out documents at the tenant level and at a newly created sibling Site Collection (no migrated material). We can check in items that have been checked out. Finally, if we upgrade the SharePoint OpenDocument class add-on for IE to version 14, it works (However, I want to reiterate that having the version 12 dll doesn't have an impact on any other SC but this one).

Mass-upgrading the dll isn't really an option for us, and since checkout works in other SCs we think this may be a configuration issue dressed in a client issue's clothing. This forum thread shows we're not alone in this issue, and we've tried most of the solutions listed here (we're getting fiddler traces now). Anyone else have any ideas?

share|improve this question
up vote 1 down vote accepted

After migrating a WSS 3.0 environment to SharePoint 2010 for a client, I was faced with this same issue. After digging around on TechNet and on here, I came to find this TechNet article:

"This document could not be checked out." SharePoint 2010 checkout action using IE8

This is not actually isolated to IE8 (I validated this by testing).

I rectified this issue by taking the advice presented at the bottom of the thread (creating a site collection at the root). There was no site collection, in my case, at the root level of the web application. After creation all check out / check in actions began to function normally.

share|improve this answer
Meant to say (a long time ago!) that, though we were assured that a site collection had been made at the root, this was never actually done. – TashasEv Apr 17 '13 at 17:39

We had the same issue, and we used a powershell script to check out and check in all the documents in a particular site collection. I'm afraid I don't have a copy of it - I didn't write it - but I understand that that fixed the problem. Once the documents had been checked out and then in, they worked correctly again.

It's almost like that after upgrade it wasn't sure if some documents were checked out or not.

share|improve this answer
Thanks for sharing. Correct me if i'm wrong, but I think that might overwrite the modified/modified by of all the documents? – TashasEv Aug 1 '12 at 16:33
Yeah, i'm not sure if it did, or if the script maybe 'discarded' the check out, rather than checking in. – Andy Burns Aug 1 '12 at 17:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.