Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Im following this article for enable RBS on sharepoint 2010 i thinks its best article for that after a lot of search : http://www.simple-talk.com/content/print.aspx?article=1280

when I try the Step 8 – Enable RBS on the Content Database with those command :

$contentDB = Get-SPContentDatabase –WebApplication <weburl>
$rbsSettings = $contentDB.RemoteBlobStorageSettings
$rbsSettings.Enable()
$rbsSettings.SetActiveProviderName($rbsSettings.GetProviderNames()[0])

on enable command i face an exception, and when I try this command its gives me false : $rbsSettings.Installed() ------False

any one can help me to continue enable RBS with this article Thanks

share|improve this question

1 Answer 1

up vote -1 down vote accepted

I run the file "RBS_X64" and go with wizard with full functionality then the command :

$rbsSettings.Installed() gives me True

then I can enable and its work fine

share|improve this answer
    
You should not install the RBS client library by double clicking the RBS_X64.msi (which will run the wizard). Instead, you must use the msiexec command to run the msi file. This is because running the wizard will set certain default values that are not recommended for SharePoint. technet.microsoft.com/en-us/library/ee748631.aspx In fact, in the article you are referencing in your question, they also mention this. –  Hossein Aarabi Sep 7 '12 at 23:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.