Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have been following this article: http://ikarstein.wordpress.com/2010/12/29/walkthrough-create-custom-sharepoint-2010-list-form-for-deployment-in-a-visual-studio-2010-project/

I have followed every step, my library is created and has a view. The custom EditForm.aspx is deployed to the right location in the hive (under the definition folder below the feature).

However, when i add a document sharepoint cannot find the edit form.

Error below - it seems to be looking the the current /Subsite/Subsite/Document Library/EditForm.aspx.

enter image description here

Any help appreciated as i've been racking my brains at this all day :S

UPDATED

Error was related to masterpage reference on custom editform page - the correct reference is below:

MasterPageFile="~masterurl/default.master"

Ok, my custom edit form is being used however, SP is ignoring my field re-arrangement (I wanted to change order of fields and hide some others).

I did not delete the DataFormWebpart from my edit form instead i modified the existing one - i guess sharepoint is removing it at runtime and adding its own???!

The author of the article created a part two - which explains exactly what I required: http://ikarstein.wordpress.com/2011/01/24/walkthrough-create-custom-sharepoint-2010-list-form-for-deployment-in-a-visual-studio-2010-project-part-2/

In the end, it was an incorrect reference to the masterpage - sorry!

thanks,

KS

share|improve this question
    
What does the <Forms> part of your schema.xml contain? –  Per Jakobsen Jul 31 '12 at 17:48
    
Updated with forms markup. thx. –  Perplexed Jul 31 '12 at 17:59
add comment

1 Answer 1

up vote 0 down vote accepted

Remove the Url="EditForm.aspx" attribute from <Form Type="EditForm" .../ >

share|improve this answer
    
No, sharepoint doesnt like that either - it needs to use that name but internally points to the custom form (according to the article). I did try removing it and sharepoint blew up - i am attaching the new error. –  Perplexed Jul 31 '12 at 18:13
    
Try setting it to Url="Forms/EditForm.aspx" –  Per Jakobsen Jul 31 '12 at 18:18
    
Tried that too! It goes back to the first popup error - 404 <sigh> –  Perplexed Jul 31 '12 at 18:36
    
Ok, checked out the log files and the error is related to the masterpage not being found - doh! Its looking for masterpage in the lists forms directory! –  Perplexed Jul 31 '12 at 18:46
    
When I change the reference to /_layouts/applicationv4.master i get a "file is not allowed on this page" (something like that). How can i reference my cusomt masterpages that are on the site? –  Perplexed Jul 31 '12 at 18:53
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.