Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have four metadata columns into which I cannot paste data for a bulk upload. A diaglog box: "The selected cells are read only" appears when I try to paste.

The cells are defined as "multiple lines of text" with up to 15 lines.

The largest thing I'm attempting to paste is 200 words, 1140 bytes. The average byte count is around 825 bytes.

I am able to paste, edit, delete and copy from all the other cells in the table, so I'm pretty confident that my Datasheet View & permissions are set up appropriately.

Three of the columns are inherited from my parent site and were created last week, one is defined on the site with which I'm working and was created this morning. I don't think that the logical location of the fields is making a difference.

The only consistency between the three is that they're all long-form text fields.

In doing my research, I discovered this question on stack which states that "It will come up saying "The selected cells are read only" if you have a multiple lines of text field that is anything other than "Plain Text" (Such as the body section of a blog post), as Datasheet view has no idea how to deal with HTML etc." I'm importing from a semi-colon delimited text file, and viewing it in a hex editor doe not reveal any hidden control characters.

I've checked my datasheet, site and column properties, and cannot see anything that would force these fields into a read-only status.

Anyone ever run into this before? Anyone know of some other things to check?

share|improve this question
    
The 15 lines just affects the size of the input area on the form, it doesn't actually limit how much you can enter. That is defined at the field type level. –  PirateEric Jul 26 '12 at 13:52
    
@PirateEric That's what I thought...but I didn't see anyplace to clear any limits. I did see the "allow unlimited is Document Libraries" radio button. That suggests to me that there may be some character limit by default...but I can't imagine it being less than 1200 bytes. –  dwwilson66 Jul 26 '12 at 14:21
    
Have you checked whether The list is set up to require content approval? If yes, then you may face the above issue. –  saumilm Jul 26 '12 at 17:34
    
@saumilm : Require content approval is set to "no". –  dwwilson66 Jul 26 '12 at 19:05
3  
You are 100% sure none of your Columns are Rich text or Enhanced rich text? –  Anders Aune Jul 27 '12 at 0:05

6 Answers 6

up vote 5 down vote accepted

From my experience, this is not possible through the SharePoint Dataview Sheet View. This is a new feature in 2010 and although super delicious and powerful, it still has a lot of issues that need to be resolved before it will be as powerful as it can be - in 2013, Microsoft has made improvements as per this article from MSDN

To answer your question - in no state are metadata columns editable in datasheet view. One of our clients had the same issue and they ended up going with ShareGate's migration tools. They have a metadata editing tool that runs for about $395

There is also a free tool on CodePlex (which I have not tried) that could be worth a try - from the comments, a lot of people found it helpful: WinForm SharePoint list item editing tool

share|improve this answer

I stumbled across a way to fix this today.

Under "Versioning Settings" there is a setting called "Require documents to be checked out before they can be edited"

By default, in all my libraries, I have this set to "Yes"

I discovered if I change that to "No" my datasheet views become read/write.

Odd? Very. But it does seem to work.

Incidentially, I flip that to "No" only when I'm going to be making mutliple changes to a document property in datasheet view. Once I'm done, I flip it back to "Yes"

share|improve this answer
1  
This actually makes sense in a Microsoft-y sort of way. Checking out a document will lock metadata fields, do if you try to edit them in datasheet view, the come us as read only. Once checkout is NOT required, the fields no longer need to be held as read-only. Granted, there may be instances where there's update contentions...but I'd rather have the bulk update take precedence over individual user settings anyway. Thanks! –  dwwilson66 Apr 16 '13 at 15:25

I had the same issue. There is another way to solve this problem with editing Multiple lines of text field in DataSheet(Access) view:

Changing Versioning Settings for lists and libraries is useless. You should change field settings in SharePoint Designer.

Open site- choose list, then right click on Multiple Line Field (with editing problem) and choose Column Settings.

In the Column Settings uncheck "Enhanced rich text (Rich text with pictures, tables, and hyperlinks)". Do not forget to save changes.

This will solve the problem

share|improve this answer

If you have Multiple lines of text columns with Rich text or Enhanced rich text, you can't edit the columns with datasheet view with office 2010 (haven't tested other offices). Tbh I haven't looked much into the reasons, only learned to live with it :)

share|improve this answer
    
Yes! Changing the Multiple Lines of Text to "Plain Text" worked for me without any other changes! Thanks!! –  Cher Reynolds Jul 16 at 12:43

I had the same issue. So I followed one of the previous posters advice and changed the Versioning Settings for libraries to "No". After the change, I still couldn't copy the data.

I went back to the Multiple lines of text field that was causing the issue, and changed the "Specify the type of text to allow" to "Plain text". I was then able to do a bulk update in in Datasheet View.

I'm not sure if the combination of changing the library setting and the text type setting worked, but the issue was resolved.

share|improve this answer

I changed the text type from 'Enhanced Rich Text' to 'Rich text' in the column setting(through List setting) from SharePoint and it worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.