SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 2 list that linked by a lookup column.

When i clicked a item of list show dispform on modal popup.

Problem is:when i click on lookup field it is open a new page.

I want show on modal popup.

in share point designer

<xsl:value-of select="@MailID" disable-output-escaping="yes"/>

if i change disable-output-escaping="no", in page show

<a onclick="OpenPopUpPage('http://mysite/_layouts/listform.aspx?PageType=4&ListId={0E7E5CF1-7382-4E32-83D0-11A298365781}&ID=12', RefreshPage); return false;" href="http://mysite/_layouts/listform.aspx?PageType=4&ListId={0E7E5CF1-7382-4E32-83D0-11A298365781}&ID=12">12</a>
share|improve this question
up vote 1 down vote accepted

I find my answer :)

Id of lookup field :

substring-before(substring-after(@MailID, 'ID='), '&#038;')

and title of lookup field :

substring-after(@MailID, '&gt;'), '&lt;')

and use Popup

onclick="OpenPopUpPage('http://mysite/_layouts/listform.aspx?PageType=4&ListId={0E7E5CF1-7382-4E32-83D0-11A298365781}&ID={substring-before(substring-after(@MailID, 'ID='), '&#038;')}', RefreshPage); return false;"
share|improve this answer

Default xsl tag for lookup field looks like
<xsl:value-of select="$thisNode/@*[name()=current()/@Name]" disable-output-escaping="yes"> try it.
PS: about disable-output-escaping.. "yes" indicates that special characters (like "<") should be output as is. "no" indicates that special characters (like "<") should be output as "<".

share|improve this answer
Thanks a lot, but i get error ! "A reference to variable or parameter 'thisNode' cannot be resolved. The variable or parameter may not be defined, or it may not be in scope." – ar.gorgin Jul 28 '12 at 4:44
try "./@*[name()=current()/@Name]" instead – Ksesh Jul 28 '12 at 17:30
No, it is not work :( – ar.gorgin Jul 29 '12 at 5:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.