SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top


I correctly set up FBA on SharePoint 2010 following these tutorials (among others):

I have one web app, with two zones, configured like the following:

  • Intranet (NTLM)
  • Extranet (FBA and NTLM)

I have set the wildcards for the people picker, the role manager and user membership providers and the connection string to the FBA database on the web.config files of Central Administration, the Intranet zone, the Extranet zone and STS.


I'm wondering why the Intranet zone (NTLM) does not get the FBA users in the people picker? If I'm on the Extranet zone (NTLM and FBA) or Central Administration the people picker works well and all the configurations are the same there.

Important note: I don't want to enable FBA on Intranet zone. but if I do, it works like a charm.

Every time I search on the people picker I got this error on the LOG:

Claims Search call failed. Error Message: Object reference not set to an instance of an object. Callstack: at Microsoft.SharePoint.WebControls.PeopleQueryControl.IssueClaimsQuery

So, is there a way to achieve this?

share|improve this question

From what I've learned from working with FBA and the people picker, FBA has to be enabled on that zone in order for the people picker to pull FBA users. You can enable FBA and use a custom login page for the Intranet zone to only authenticate via NTLM (even though FBA is enabled).

I had a post about this recently:

NTLM Authenticated Application, FBA, and the People Picker

And answered this post:

SharePoint People Picker look-up for asp net membership provider not working

I hope this helps you.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.