Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Background:

We are migrating from Sharepoint 2007 to Sharepoint 2010. We have a custom list with 75 columns, of which 2 columns are lookup fields, 10 are multi-line text fields and 4 are people pickers. Rest of the columns are single line of text fields. A Sharepoint Designer workflow is attached to the list which would be triggered on Item addition.

Problem:

While adding a new item from the NewForm.aspx after filling in all the fields (both mandatory and non-mandatory ones) and clicking the "Save" button, the page is getting refreshed and the all the data is gone from the controls on the page. We tried filling in the details again and saving but the page gets refreshed every time with clear controls. When we click on the cancel button and come back to the list view, we dont find the item added.

There are no CEWP or javascripts attached to the page. Newform.aspx has not been tampered with in the SP Designer.

We can't check in the logs as well because there is no error being thrown but only page refresh.

Kindly provide an answer.

share|improve this question
    
Did you try migrating the same on a different 2007 environment first and verify the problem occurs in that scenario as well ? –  Arko D Jul 23 '12 at 11:26
    
What is the error being thrown on refresh? –  Dave Wise Jul 23 '12 at 15:17
    
There is no error being thrown. I have done the same in the Dev box and its working fine there. When trying to migrate the same to Integration env, the problem occurs. –  Glimpse09 Jul 24 '12 at 9:02
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.