Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

There is a sharepoint intranet site http://server_name:port with DNS xyz pointed to server_name.

The issue could be realted to the way i have configured AAM. Here is the background about what was done.

  • I added new binding in IIS with port 80 and host name xyz.

  • Configured alternate access mapping for the site collection by adding new mapping for intranet with http://xyz.

  • There is a search application configured and i had to include http://xyz in the search scope to get the items in the site crawled. The items crawled was 0 when the search scope was default address of the site.

  • I have not removed http://server_name:port from the scope and hence i get this crawl error.

"This item could not be crawled because the crawler could not connect to the repository"

Now I access the site using http://xyz and try a search query, the result returns nothing! I checked the log it seems the items are getting queried. I also get this error in the LOG

Error getting element ProxyUrl: System.ArgumentNullException: Value cannot be null.  Parameter name: xDoc 
at Microsoft.Office.Server.Search.Administration.LocationConfiguration.getElements(XmlDocument xDoc, String elementName, String nameSpace)
 at Microsoft.Office.Server.Search.Administration.LocationConfiguration.getElementString(XmlDocument xDoc, String elementName, String nameSpace)

Please let me know how to get over this issue. Thanks!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You may need to set Sever Name Mappings in the Search Service Application. Essentially, you specify the address at which the content will be crawled (this can be http://server_name:port) and the address (http://xyz) that will be displayed in search results.

Its quite unlikely you need to set bindings in your IIS if the DNS name has been configured correctly to point to your SharePoint WFE or the NLB (if used) and alternate access mappings are configured correctly. Just ensure your public url for the default zone remains the same as the DNS name. Your internal url should be (http://servername:port).

share|improve this answer
    
Thanks a lot for your help! I had to add the mapping in Search service, also the second part of your answer prompted me to make correction on how i had configured AAM. –  Shankar Jul 23 '12 at 8:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.