Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Our Incoming mail are not posting to lists. Some sites are able to get the incoming mail but they are different on databases. Some sites which are on different content database incoming mail is not posting to the lists. All the sites have same App server and web server. I can see incoming e-mail in Drop folder if I set the setting as save the e-mail in Drop folder.

Can somebody help? I am new to Sharepoint 2010.

share|improve this question
    
Are all of these sites (both working and non) on the same Web Application, i.e. someUrl.domain.com or on different web apps? –  Dave Wise Jul 20 '12 at 15:12
    
Both of them are the same web application. –  Chetna Jain Jul 20 '12 at 15:20
    
Was this site migrated to SharePoint 2010 from 2007 recently? –  Dave Wise Jul 20 '12 at 15:33
    
No its been more than 6 months. All other sites are getting e-mail its just one site which is not working. I just tried to created a new site with same database and the e-mail is posted to this new site. Is there any site setting which I should be looking at? –  Chetna Jain Jul 20 '12 at 15:48
    
I have tried the deleting the settings and still it didn't work. I tried to create another discussion and set the e-mail setting and it is not working on this particulatr site. –  Chetna Jain Jul 20 '12 at 17:58

1 Answer 1

There is a bug where, under certain conditions (usually related to 2007-2010 upgrade or when a server name changes) a list will become 'stuck' where it cannot receive email. The fix is fortunately extremely simple and painless :

  • Go to the list properties and select 'Incoming Email Settings'
  • Copy the current email address to someplace else, like Notepad++
  • Change the 'Allow this list to receive e-mail' to 'No' and hit 'OK'
  • Go back into the incoming email settings for the list
  • set the 'Allow this list to receive e-mail' to 'Yes' and paste the original address back in and hit ok.
  • Go back into the incoming email settings and make a note of the FULL email address required. Usually this is something like 'listname@sharepoint.domain.com'
  • Send email to the address as it appears in SharePoint

If that doesn't work, check the permissions on the list and make sure that whoever is testing the email functionality has at least 'contribute' permissions to the list. Either that or enable the 'Accept e-mail messages from any sender' option, though this is only advisable in a controlled Intranet environment.

share|improve this answer
    
have tried the deleting the settings and still it didn't work. I tried to create another discussion and set the e-mail setting and it is not working on this particulatr site. –  Chetna Jain Jul 20 '12 at 18:18
    
Is there anything in the SharePoint logs around the time that the email arrives in the Drop folder? –  Dave Wise Jul 20 '12 at 18:48
    
No I don't see anything in the logs too...........Apparently all the sites are working fine. It is just one site and then its child sites. –  Chetna Jain Jul 20 '12 at 18:54
    
The user that is being used to send the emails has 'Contribute' permissions to the list, right? –  Dave Wise Jul 20 '12 at 18:59
    
Yes it does. Infact it has full control –  Chetna Jain Jul 20 '12 at 18:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.