Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I opened my list in datasheet view. But I wasn't able to edit in that view - things were read only. How do I enable edition in datasheet view?

share|improve this question
    
Please describe a little more in details. Is your datasheet view disabled or do you get any errors when you try to open the list on a datasheet view. –  Arko D Jul 18 '12 at 12:07
add comment

3 Answers

Make sure you've configured the Datasheet section of Advanced Settings in List Settings. You should be able to edit the list in datasheet view, if the radio button is checked to "Yes" under "Allow items in this list to be edited using the datasheet and you have the correct permissions to modify the list.

share|improve this answer
add comment

In addition to what Kambridge has added you also need to ensure you have correctly installed Office 2007 Data Connectivity Component in the client system. This is used by the Datasheet view.

share|improve this answer
add comment

I had this issue.

Create a new data sheet 'view' and remove all system columns which are read only (created by, modified date, etc.). I only have Name, Desc, and my custom meta columns.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.