Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Does anyone know what I am doing wrong, I get the error below when installing the pre-requisites. It did the first round of updates then i rebooted and on the second lot of installs this came up. I've since tried rebooting and doing windows updates and still having the same problem

Error:

the tool was unable to install aplication server role, web server iis role 2013 preview

Any ideas?

enter image description here

share|improve this question
    
Which OS are you installing on? –  Per Jakobsen Jul 17 '12 at 19:59
    
Windows 2008 R2 Datacenter –  Andi Jul 17 '12 at 20:03
    
Could be missing SP1 –  Per Jakobsen Jul 17 '12 at 20:08
1  
Just checked and SP1 is installed (if you mean sp1 for the os) –  Andi Jul 17 '12 at 20:10
    
Added an image of the services installed. It's a new server I've just had setup. –  Andi Jul 17 '12 at 20:17
add comment

2 Answers

up vote 0 down vote accepted

My issue was that I was running an older version of SQL Server than was supported, as pointed out in a comment above.

Requirements as follows:

Minimum software requirements This section provides minimum software requirements for each server in the farm.

Minimum requirements for a database server in a farm:

One of the following:

The 64-bit edition of Microsoft SQL Server 2012.

The 64-bit edition of SQL Server 2008 R2 Service Pack 1

The 64-bit edition of Windows Server 2008 R2 Service Pack 1 (SP1) Standard, Enterprise, or Datacenter or the 64-bit edition of Windows Server 2012 Standard or Datacenter

The SharePoint parsing process crashes in Windows Server 2008 R2 (KB 2554876)

FIX: IIS 7.5 configurations are not updated when you use the ServerManager class to commit configuration changes (KB 2708075)

Hotfix: ASP.NET (SharePoint) race condition in .NET 4.5 RTM:

Windows Server 2008 R2 SP1 (KB 2759112)

Windows Server 2012 (KB 2765317)

Microsoft .NET Framework version 4.5

Minimum requirements for a single server with built-in database:

The 64-bit edition of Windows Server 2008 R2 Service Pack 1 (SP1) Standard, Enterprise, or Datacenter or the 64-bit edition of Windows Server 2012 Standard or Datacenter

The SharePoint parsing process crashes in Windows Server 2008 R2 (KB 2554876)

FIX: IIS 7.5 configurations are not updated when you use the ServerManager class to commit configuration changes (KB 2708075)

Hotfix: ASP.NET (SharePoint) race condition in .NET 4.5 RTM:

Windows Server 2008 R2 SP1 (KB 2759112)

Windows Server 2012 (KB 2765317)

The Setup program installs the following prerequisite for a single server with built-in database:

Microsoft SQL Server 2008 R2 SP1 - Express Edition

The Microsoft SharePoint Products Preparation Tool installs the following prerequisites for a single server with built-in database:

Web Server (IIS) role

Application Server role

Microsoft .NET Framework version 4.5

SQL Server 2008 R2 SP1 Native Client

Microsoft WCF Data Services 5.0

Microsoft Information Protection and Control Client (MSIPC)

Microsoft Sync Framework Runtime v1.0 SP1 (x64)

Windows Management Framework 3.0 which includes Windows PowerShell 3.0

Windows Identity Foundation (WIF) 1.0 and Microsoft Identity Extensions (previously named WIF 1.1)

Windows Server AppFabric

Cumulative Update Package 1 for Microsoft AppFabric 1.1 for Windows Server (KB 2671763)

Minimum requirements for front-end web servers and application servers in a farm:

The 64-bit edition of Windows Server 2008 R2 Service Pack 1 (SP1) Standard, Enterprise, or Datacenter or the 64-bit edition of Windows Server 2012 Standard or Datacenter.

The SharePoint parsing process crashes in Windows Server 2008 R2 (KB 2554876)

FIX: IIS 7.5 configurations are not updated when you use the ServerManager class to commit configuration changes (KB 2708075)

Hotfix: ASP.NET (SharePoint) race condition in .NET 4.5 RTM:

Windows Server 2008 R2 SP1 (KB 2759112)

Windows Server 2012 (KB 2765317)

The Microsoft SharePoint Products Preparation Tool installs the following prerequisites for front-end web servers and application servers in a farm:

Web Server (IIS) role

Application Server role

Microsoft .NET Framework version 4.5

SQL Server 2008 R2 SP1 Native Client

Microsoft WCF Data Services 5.0

Microsoft Information Protection and Control Client (MSIPC)

Microsoft Sync Framework Runtime v1.0 SP1 (x64)

Windows Management Framework 3.0 which includes Windows PowerShell 3.0

Windows Identity Foundation (WIF) 1.0 and Microsoft Identity Extensions (previously named WIF 1.1)

Windows Server AppFabric

Cumulative Update Package 1 for Microsoft AppFabric 1.1 for Windows Server (KB 2671763)**

share|improve this answer
add comment

Verify if you have Iisext.vbs in the c:\windows\system32 folder. If this file is not available, activate the Web service (IIS) management tools via the add roles and features wizard.

share|improve this answer
    
It is there. I only have SQL 2005 - is 2008 required? –  Andi Jul 17 '12 at 21:05
    
You SQL Server 2008 R2 SP1. technet.microsoft.com/en-us/library/cc262485(office.15).aspx –  Hossein Aarabi Jul 17 '12 at 21:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.