Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

We are using SharePoint 2010. I have permission (full access) on my site. I have three uploaded files (one Word .doc, one Excel .xls, one CSV .csv).

I had no problems editing Word and Excel files. But I could not edit CSV file. Even "Edit Document" button on CSV file was disabled (greyed off). The file is a read-only file.

Could anyone help me on this issue? Why does CSV file have difference behavior from other file formats in SharePoint? I tried to search but could not find anything from the web.

share|improve this question
add comment

migrated from stackoverflow.com Jul 17 '12 at 2:50

This question came from our site for professional and enthusiast programmers.

1 Answer

Add the following to DOCICON.XML (default location is C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\XML)

<Mapping Key="csv" Value="icxltx.png" OpenControl=""/>

Then in IIS Manager select the server and then select MIME Types, update the entry for csv to 'application/vnd.ms-excel'.

This will allow you to click the file name link and have the file open in Excel however the edit document button will still be disabled.

Source: http://nickgrattan.wordpress.com/2011/01/05/sharepoint-opening-csv-files-with-microsoft-excel/ (Nick Grattan’s SharePoint Blog)

share|improve this answer
    
Thanks quila Sands! How can I make the Edit Document enabled for CSV file? Any suggestions? Thanks a lot. YK –  user9512 Jul 17 '12 at 18:22
1  
@Yan. That will require some custom development to create an OpenDocuments control that knows how to handle a csv file. You could then specify this control in the OpenControl attribute of the Mapping XML element. This blog post has more info and a project that can provide a starting point. –  Aquila Sands Jul 18 '12 at 9:50
    
Thank you very much Aquila Sands! After copy over xls's mapping then change xls to csv: <Mapping Key="csv" Value="icxltx.png" OpenControl="SharePoint.OpenDocuments"/>. CSV files now are editable from SharePoint. Issue resolved! –  user9512 Jul 18 '12 at 20:15
    
Please mark the answer appropriately so anyone could benefit from! –  C. Marius - MVP Jan 13 '13 at 10:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.