Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Is there some way for me to simply "re-initialize" SharePoint Foundation Search in 2010?

Simply clicking on the SharePoint Foundation Search in Central Admin -> Services on Server yields: Object reference not set to an instance of an object... I can't do anything with it via Central admin, attempts to start it or modify its settings give me that error. Nothing in the ULS log, nothing in the event log.

I can execute Get-SPSearchService / Get-SPSearchServiceInstance and see some results. Is there some way to just wipe it and start over -- without affecting the web application I've built?

I was simply trying to get the search functionality working and I have somehow made things worse in that now Central Admin will have nothing to do with the SharePoint Foundation Search service...

EDIT -

I rebooted and now get a slightly better error message:

Some or all identity references could not be translated.

I am trying to update the managed account and the crawl account but am unable to do so via Central Admin -- I've tried the following to no avail:

set-spsearchservice -identity eb2babc1-2828-4153-b39f-49738809a526 -crawlaccount domain\sp_crawl -crawlpassword (convertto-securestring "12345" -AsPlainText -force)

Powershell just stares blankly at me I'm not sure anything was accomplished.

share|improve this question
add comment

1 Answer 1

For anyone who may come across a problem like this,

It appears the problem may have been caused by using a domain\username that exceeded 20 characters.

I was able to repair the situation by creating new users with shorter usernames and updating the settings outside of central admin (via powershell commands)

stsadm -o spsearch -farmserviceaccount <domain>\<serviceaccountname> -farmservicepassword <password>

(ok, maybe you can run stsadm outside powershell but that is where I ran it) and:

set-spsearchservice -identity <service ID gleaned from get-spsearchservice> -crawlaccount <domain>\<crawl account name> -crawlpassword (convertto-securestring "<password>" -AsPlainText -force)

I hope this can help someone out.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.