Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm trying to add a column of type Metadata. I've first exported the SchemaXml of an existing column on which i'm working. After that I added the column with method AddAsSchemaXml.

The field is here, and I can see that it has choosen the right metadata. My problem is that when I try to add an item, the field doesn't want to save.

Do you have any ideas where it comes from ?

share|improve this question
    
what kind of error do you get when you save? Please paste your XML at the question too. Also try to avoid comments in your XML or parsing will fail –  Anders Rask Jul 13 '12 at 8:03
    
Hey I've succeed managing that by modifying my powershell function. I look if the type of my field is metadata, and then I add the metadata not with the AddFieldAsXml function but create the field with Fields.Add() Thanks –  Thoma Bigueres Jul 13 '12 at 8:52
    
If that was the answer, create an answer and mark as answer (might take a few days before you can mark as answer) –  Anders Rask Jul 13 '12 at 11:26
add comment

1 Answer 1

up vote 0 down vote accepted

I've succeed managing that by modifying my powershell function. I look if the type of my field is metadata, and then I add the metadata not with the AddFieldAsXml function but create the field with Fields.Add()

Thanks

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.