Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to publish an InfoPath form to a SharePoint form library, but I am running into problems. Immediately after clicking the Next button in the Publishing Wizard, I receive "You are not authorized to perform the current operation" error. I am a site collection admin on the site.

Tracing the operation in Fiddler, I am getting a 403 error accessing /_vit_bin/shtml.dll/_vti_rpc. The full trace is below.

Query:

POST https://testsite/_vti_bin/shtml.dll/_vti_rpc HTTP/1.1
Date: Wed, 11 Jul 2012 21:09:50 GMT
MIME-Version: 1.0
User-Agent: MSFrontPage/14.0
Host: cbs.gsk.com
Accept: auth/sicily
Content-Length: 42
Content-Type: application/x-www-form-urlencoded
X-Vermeer-Content-Type: application/x-www-form-urlencoded
Connection: Keep-Alive
Cache-Control: no-cache

method=server+version%3a14%2e0%2e0%2e6009

Reply:

HTTP/1.1 403 FORBIDDEN
Content-Type: text/html; charset=utf-8
Server: Microsoft-IIS/7.5
SPRequestGuid: d905e7ac-6ae4-4c7d-a5c9-51533f768db8
X-SharePointHealthScore: 2
X-Forms_Based_Auth_Required: https://testsite/_login/default.aspx?ReturnUrl=/_layouts/Error.aspx&Source=%2f_vti_bin%2fshtml.dll%2f_vti_rpc
X-Forms_Based_Auth_Return_Url: https://testsite/_layouts/Error.aspx
X-MSDAVEXT_Error: 917656; Access denied. Before opening files in this location, you must first browse to the web site and select the option to login automatically.
X-Powered-By: ASP.NET
MicrosoftSharePointTeamServices: 14.0.0.6106
Date: Wed, 11 Jul 2012 21:09:50 GMT
Content-Length: 13

403 FORBIDDEN

How do I fix this problem? Is there some setting in SharePoint or IIS I need to tweak or enable?

share|improve this question
    
Please clarify are you trying to a create a custom list through Infopath ? –  Arko D Jul 12 '12 at 7:44
    
No, actually it is simpler than that. I just want to publish a form to a doc lib. The error coming back is a SharePoint access-denied error. Looking for insights as to what might be going wrong. –  Wade Henderson Jul 12 '12 at 14:27
    
From curiosity, why are you trying to publish Infopath form into document library but onto from library? –  Gennady Vanin Геннадий Ванин Jul 14 '12 at 13:06
    
@WebMAOhist Thanks, you're right, it is a form library. I will correct the text above. –  Wade Henderson Jul 16 '12 at 12:21

2 Answers 2

"I am a site collection admin on the site"

IMO, This is irrelevant for publishing Infopath form library. If the form (for example, client/Filler) requires a "Full trust" then the security level warning is issued and specified on the client Infopath Designer 2010 which does not know anything about server accesses and then activated on Sharepoint Server 2010 by farm administrator.
And that activation requires farm administrator privileges but not site collection administrator's one.

Also, why are you publishing and Infopath form onto document library but not to a form library?
Is it:

  • in Sharepoint\Infopath 2010 ? 2007? 2003?
  • in Office 365 (Sharepoint 2010 Online) ?
  • browser or client/Filler form?
  • etc.

Can you provide step-by-step indtructions in order to reproduce your error?

Update:
I've just checked in Fiddler2 what is requested and gotten back on pressing Next in publishing wizard to my Sharepoint Online (Office 365) site:

Request1:

CONNECT gennadyxxxxx.sharepoint.com:443 HTTP/1.0    
User-Agent: Microsoft Office Protocol Discovery   
Host: gennadyxxxxx.sharepoint.com:443   
Content-Length: 0   
Connection: Keep-Alive   
Pragma: no-cache   

A SSLv3-compatible ClientHello handshake was found. Fiddler extracted the parameters below.  

Major Version: 3  
Minor Version: 1  
Random: 50 04 41 2D 7A 88 5B 8F A7 0E 0D C0 50 37 6A 31 AE 0E D2 49 89 33 E2 ED 9D 25 81 8F   F8 F7 22 B7  
SessionID: 8D F5 C4 48 37 95 B6 3E 4B AF 97 4F 99 75 0C 84 73 14 F8 1F D1 65 0D 56 F0 A1 CA 43 5F 34 AA 50  
Ciphers:   

[0004]  SSL_RSA_WITH_RC4_128_MD5  
[0005]  SSL_RSA_WITH_RC4_128_SHA  
[000A]  SSL_RSA_WITH_3DES_EDE_SHA
[0009]  SSL_RSA_WITH_DES_SHA  
[0064]  TLS_RSA_EXPORT1024_WITH_RC4_56_SHA  
[0062]  TLS_RSA_EXPORT1024_WITH_DES_SHA  
[0003]  SSL_RSA_EXPORT_WITH_RC4_40_MD5  
[0006]  SSL_RSA_EXPORT_WITH_RC2_40_MD5  
[0013]  SSL_DHE_DSS_WITH_3DES_EDE_SHA  
[0012]  SSL_DHE_DSS_WITH_DES_SHA  
[0063]  TLS_DHE_DSS_EXPORT1024_WITH_DES_SHA  

Compression:   
[00]    NO_COMPRESSION  

Extensions: 
none

Response1:

HTTP/1.1 200 OK    
HTTP/1.0 200 Connection Established    
FiddlerGateway: Direct    
StartTime: 00:03:52.984    
Connection: close    

Encrypted HTTPS traffic flows through this CONNECT tunnel. HTTPS Decryption is enabled in Fiddler, so decrypted sessions running in this tunnel will be shown in the Web Sessions list.    

Request2:

OPTIONS https://gennadyxxxxx.sharepoint.com/ HTTP/1.1    
User-Agent: Microsoft Office Protocol Discovery    
Host: gennadyxxxxx.sharepoint.com    
Content-Length: 0    
Connection: Keep-Alive    
Cookie: FedAuth=77u/PD....truncated_too_lengthy         

Response2:

HTTP/1.1 200 OK    
Cache-Control: private,max-age=0    
Allow: GET, POST, OPTIONS, HEAD, MKCOL, PUT, PROPFIND, PROPPATCH, DELETE, MOVE, COPY, GETLIB, LOCK, UNLOCK    
Content-Length: 0    
Expires: Sun, 01 Jul 2012 17:04:40 GMT    
Accept-Ranges: none    
Server: Microsoft-IIS/7.5    
SPRequestGuid: 02e216bc-5930-4da6-93f8-cfd19858e9c2    
X-SharePointHealthScore: 0    
MS-Author-Via: MS-FP/4.0,DAV    
X-MSDAVEXT: 1    
DocumentManagementServer: Properties Schema;Source Control;Version History;    
X-MSFSSHTTP: 1.0    
DAV: 1,2    
Public-Extension: http://schemas.microsoft.com/repl-2    
X-Powered-By: ASP.NET    
MicrosoftSharePointTeamServices: 14.0.0.6109    
P3P: CP="ALL IND DSP COR ADM CONo CUR CUSo IVAo IVDo PSA PSD TAI TELo OUR SAMo CNT COM INT NAV ONL PHY PRE PUR UNI"v
Date: Mon, 16 Jul 2012 17:04:40 GMT    

Request3:

POST https://gennadyxxxxx.sharepoint.com/_vti_bin/webs.asmx HTTP/1.1    
Content-Type: text/xml; charset=utf-8    
SOAPAction: http://schemas.microsoft.com/sharepoint/soap/WebUrlFromPageUrl    
X-Office-Version: 14.0.4760    
User-Agent: Microsoft Office/14.0 (Windows NT 5.1; InfoPath Editor 14.0.4760; Pro)    
Host: gennadyxxxxx.sharepoint.com    
Content-Length: 325    
Connection: Keep-Alive    
Cache-Control: no-cache    
Cookie:         FedAuth=77u/PD94bWwgdmVyc2lvbj0........    

<?xml version="1.0" encoding="utf-8"?>    
    <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">    
        <soap:Body>    
            <WebUrlFromPageUrl xmlns="http://schemas.microsoft.com/sharepoint/soap/">    
            <pageUrl>https://gennadyxxxxx.sharepoint.com/msdn_SBS_FormLib_Publish</pageUrl>  
        </WebUrlFromPageUrl>    
    </soap:Body>
</soap:Envelope>

Response3:

HTTP/1.1 200 OK    
Cache-Control: private, max-age=0    
Content-Type: text/xml; charset=utf-8    
Server: Microsoft-IIS/7.5    
SPRequestGuid: b2067545-c868-4539-a7d4-11a9468ee01a    
X-SharePointHealthScore: 0    
X-AspNet-Version: 2.0.50727    
X-Powered-By: ASP.NET    
MicrosoftSharePointTeamServices: 14.0.0.6109    
P3P: CP="ALL IND DSP COR ADM CONo CUR CUSo IVAo IVDo PSA PSD TAI TELo OUR SAMo CNT COM     INT NAV ONL PHY PRE PUR UNI"    
Date: Mon, 16 Jul 2012 17:04:40 GMT    
Content-Length: 441        

<?xml version="1.0" encoding="utf-8"?>    
    <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
        <soap:Body>    
            <WebUrlFromPageUrlResponse xmlns="http://schemas.microsoft.com/sharepoint/soap/">       
               <WebUrlFromPageUrlResult>
                    https://gennadyxxxxx.sharepoint.com
            </WebUrlFromPageUrlResult>
    </WebUrlFromPageUrlResponse>
</soap:Body></soap:Envelope>  

Request4: OPTIONS https://gennadyxxxxx.sharepoint.com/ HTTP/1.1 User-Agent: Microsoft Office Protocol Discovery Host: gennadyxxxxx.sharepoint.com Content-Length: 0 Connection: Keep-Alive Cookie:
FedAuth=77u/PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0idXRmLTgiP.........

Response4:

HTTP/1.1 200 OK    
Cache-Control: private,max-age=0    
Allow: GET, POST, OPTIONS, HEAD, MKCOL, PUT, PROPFIND, PROPPATCH, DELETE, MOVE, COPY, GETLIB, LOCK, UNLOCK    
Content-Length: 0    
Expires: Sun, 01 Jul 2012 17:04:40 GMT    
Accept-Ranges: none    
Server: Microsoft-IIS/7.5    
SPRequestGuid: b7f36372-91cc-4408-bd73-ac19b4ce51c9    
X-SharePointHealthScore: 0    
MS-Author-Via: MS-FP/4.0,DAV    
X-MSDAVEXT: 1    
DocumentManagementServer: Properties Schema;Source Control;Version History;    
X-MSFSSHTTP: 1.0    
DAV: 1,2    
Public-Extension: http://schemas.microsoft.com/repl-2    
X-Powered-By: ASP.NET    
MicrosoftSharePointTeamServices: 14.0.0.6109    
P3P: CP="ALL IND DSP COR ADM CONo CUR CUSo IVAo IVDo PSA PSD TAI TELo OUR SAMo CNT COM INT NAV ONL PHY PRE PUR UNI"    
Date: Mon, 16 Jul 2012 17:04:40 GMT      

etc.

The first dialog window of Infopath Designer 2010 Publishing Wizard before clicking Next button for the 1st time:

1st dialog of Publishing Wizard from Infopath Designer 2010

Update 3:
Going to sleep.

I am on Sharepoint Online (Office 365) site, OOTB. Before that I used on-premise Sharepoint Server 2010 mounted in virtual machine, taken again somewhere from MS on internet, OOTB. Never used claims. AFAIU, NTLM or claims is irrelevant since Infopath uses its own Microsoft Office Protocol and at application level the browser based IP forms communicate with server over XMLHTTP (which is related with necessity to resolve the double hop authentication issues) while client/Filler forms via NTLM (that do not have the double hop issues).

Check that WebDAV is enabled on your server.

IMO Infopath uses Microsoft Office Protocol Discovery so check for compatibility of your server configuration with it.

share|improve this answer
    
SharePoint 2010 and InfoPath 2010. Create any form (even a blank form) and try to publish it. I receive this error on the first step of the wizard. This is to an on-premises farm. I have been mainly testing browser-based forms, but it is before that step the error occurs. I am mainly concerned as to why I am getting a access denied on the virtual directory. –  Wade Henderson Jul 16 '12 at 12:22
    
virtual directory? Virtual directories are not created while using Sharepoint Server. Even more you should configure IIS serving non-sharepoint site and sharepoint webapps served thru distinctive ports. BTW, I've been doing it thousands times in on-premises Sharepoint Server 2010 and now onto Sharepoint Online (Office 365). BTW, from Windows XP SP3 32-bit –  Gennady Vanin Геннадий Ванин Jul 16 '12 at 16:21
    
Ok, any thoughts why I would get a 403 accessing this path: testsite/_vti_bin/shtml.dll/_vti_rpc –  Wade Henderson Jul 16 '12 at 17:21
    
My guess is that you are trying to publish onto non-sharepoint IIS site (virtual directory). I do not now have any at hand to check it. Are you publishing from the same machine where Sharepoint Server runs or remotely? –  Gennady Vanin Геннадий Ванин Jul 16 '12 at 18:02
    
Also, before 1st NEXT clicking in Publishing Wizard you should not specify yet library locatuon but simply your sharepoint site _http://somthing_like_SharepointTestMachine/ –  Gennady Vanin Геннадий Ванин Jul 16 '12 at 18:12

I had a similar issue with "You are not authorized to perform the current operation" when publishing to a HTTPS destination. The form template was set to Full Trust (Central Admin Administrator Approved). However InfoPath wants to "see" that URL and confirm it's a valid destination.

I opened the HTTPS website in IE. By clicking "View Certificate" then "Install Certificate" I was able to FIX the issue by adding to my local Trusted Root Certification Authorities. Hope that helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.