Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a generic list of items in SharePoint 2010.

When I select an item with the left column checkbox, then select Delete Item from the ribbon, the item does not delete. Looking at the traffic in Fiddler, I am receiving an Access Denied response. I am a SC admin, and have full control to the list and recycle bin.

When I select the exact same item, and use the context menu (ECB) Delete Item choice, the item is deleted. When I check the recycle bin, the item is present, so it did delete successfully. Fiddler traffic looks normal.

What can explain this behavior? How can I correct it so that the ribbon Delete Item button works?

By the way, this a claims-based auth environment, in case that matters.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Based on a tip here from Donal Conlon, I discovered that the IIS web site did not have Anonymous access enabled. I enabled Anonymous for the virtual root site, and now the ribbon delete is working.

I am working through the other security implications of making this change, but it appears that claims is still authenticating correctly and I have proper access to the site. The only difference I can see so far is that I can now browse to the web service endpoints (before I was getting Access Denied there).

share|improve this answer

May have partially answered my own question. I believe the access denied is to the request for this URL:

https://testsites.com/sites/testsite/_vti_bin/client.svc/ProcessQuery

I'm now investigating permissions to this service.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.