Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have a custom list on my (Human Resource Department) sub-site where HR user fills two to three fields and attach a word document.

On HR site the permissions are not inheritted and I made custom permissions for this HR user and he has "Contribute" rights.

Whenever he clicks on "Add new" it shows the form fields but no attachment option along with the editing toolbar. When I log in (I am site collection administrator) I can see the editing bar. Please take a look at the attached picture and want users to see the editing toolbar like this.

enter image description here

share|improve this question
    
Did you tried to give next level "Design"? Did it work? Do you have other cases where "Contribute" was enough to attach files? Did you do "Check Permissions"? I know, SP has a nonpermissive rights management, but it is not that easy to look through. –  Shegit Brahm Jul 11 '12 at 7:37
    
Checked everthing..Design permission I cannot give but I did this too for testing and still no Edit bar. This is very strange behaviour I must say. In Library advance settings the attachments are allowed but my concern is editing bar. –  user342944 Jul 11 '12 at 8:03
    
Its a permissions issue for sure. Did you make a custom permission level or just used the existing "Contribute" permission level for the HR user ? I am guessing you did not modify the contribute permission level. –  Arko D Jul 11 '12 at 8:58
    
I have one site collection called (Home) ..and then the subsites like HR, Finance, Legal...and on every subsite stage I've stopped Inheritence and customized the permissions. For document libraries and Custom Lists I've customized the permissions and granted individuals on different custom lists. I've checked the Contribute Permission level they have "Add Item", "Delete Item, Edit Item" permissions .. –  user342944 Jul 11 '12 at 9:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.