SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Sharepoint farm on and all my staff on domain. is the one way trust domain. I am able to find and add users in "Local ussers and groups", but not able to find in sharepoint people picker.

I did following steps still not resolved.

  1. stsadm -o setapppassword -passowrd

    1. stsadm -o setproperty -url -pn peoplepicker-searchadforests -pv "", XXX\user,

I am troubleshooting this since morning... not resolved..

share|improve this question

The format of the command is ",username,password".

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

even i tried this.. – James123 Jul 10 '12 at 13:58
Please make sure the appropriate ports are open from your DMZ SharePoint Server(s) to your internal Domain Controllers. See…. – Trevor Seward Jul 10 '12 at 16:21
is different ports than the Local ussers and group access?. Because I can access users from "Local ussers and group" in the farm. Not in SharePoint picker – James123 Jul 10 '12 at 19:54
Take a look at the blog post. Try telneting from the SharePoint Server to some of the ports on your internal Domain Controllers. If that doesn't work, then the People Picker cannot reach the internal Domain Controllers. – Trevor Seward Jul 10 '12 at 20:43
@Travor: I got interesting thing in ULS logs... Why peoplepicker searching SQL server when search for domain user? see these errors Error in searching user 'ehq\auseovach' : System.Web.HttpException: Unable to connect to SQL Server database. ---> System.Data.SqlClient.SqlException: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locatin – James123 Jul 10 '12 at 21:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.