SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a sharepoint site with a list, loaded from an external content type with Sharepoint designer. The list limit is 30. Below the list, a data pager is shown to navigate through the pages.

                             1-30 ->

On another list with the same limit and more than 30 items, the pager is not shown. Paging is possible only by using the task bar (List Tools -> List -> Navigate). How can I make the data pager appear?

share|improve this question
Have you tried creating a new view on that list? Does the pager appear for that? – Andy Burns Jul 9 '12 at 16:34
I have tried that now. The pager does not appear. – AGuyCalledGerald Jul 9 '12 at 16:46

"How can I make the data pager appear?"->If the number of list items did not reach the page limit, the pager do not appear.

Actually, I couldn't understand your question. But, I guess, if u want to show the pager even list items did not reach the list limit, you can use javascript.

share|improve this answer
Yes, there are more than 30 items, see my edit. – AGuyCalledGerald Jul 9 '12 at 12:29
There are two options in the list view settings, below ItemLimit property. I think you must choose the first one. I guess it must be "Show items in certain number of groups" or like this. – compengTR Jul 9 '12 at 12:40
in both lists the first option is chosen, but only in one list is the pager. – AGuyCalledGerald Jul 9 '12 at 13:17
up vote 0 down vote accepted

Actually, the pager vas visible, but because the list was wider than the page, it showed up far to the right, so I had to scroll horizontally to find it!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.