SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Really need help with this issue. I've been struggling for about 4 hours today with this issue and no luck.. Tried everything and every article out there but obviously missed something.

Here's the issue. My web app is setup with Claims and I'm using the dual auth with windows and forms based. Windows auth works fine.

Since today, I keep on getting the following exception :

SPSecurityTokenService.Issue() failed: System.ArgumentException: Cannot get Membership Provider with name XXXXX. The membership provider for this process was not properly configured. You must configure the membership provider in the .config file for every SharePoint process.

The change that was made, was a solution deployment which I guess made web.config changes that I dont' know of. I've tried rolling back web.configs, reconfiguring the membership providers to no avail.

Herewith my web.config for the affected web app:

<membership defaultProvider="XXXXXXX">
        <remove name="AspNetSqlMembershipProvider" />
        <add name="XXXXXXX" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="XXXXXXX" enablePasswordReset="false" enablePasswordRetrieval="false" passwordFormat="Clear" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" applicationName="XXXXXXX" />

Any advice appreciated.

share|improve this question
up vote 1 down vote accepted

Ok. I managed to solve it.

You have to also update your membership and roles settings in the SecurityToken WCF service found here : C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\WebServices\SecurityToken

I was updating the incorrect web.config for the STS found here C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\isapi\sts.

share|improve this answer
Please do not forget to mark this as your accepted answer – Robert Lindgren May 3 '14 at 10:49
You probably want to do that also in your central admin web.config – Amadeo Gallardo May 3 '14 at 13:58

In my case, I was using multiple SharePoint Front End servers. The membership provider entry was not properly configured on every Front End server.

The web.config can be found on each server here: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\WebServices\SecurityToken

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.