Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have encountered strange problem on my dev VM.

Background: Having my VM open (VM Player), I put host computer into sleep mode, then I woke it and put into sleep mode for second time. After waking it up second time, it was slow as hell so I decided to restart it. But since it's responsivenes was close to 0, I used VMware "Power off" option. After rebooting VM, everything seems ok, but in VS 2010 I'm getting:

Error occurred in deployment step 'Recycle IIS Application Pool': Cannot connect to the SharePoint site: https://xxx.yyy.local. Make sure that this is a valid URL and the SharePoint site is running on the local computer. If you moved this project to a new computer or if the URL of the SharePoint site has changed since you created the project, update the Site URL property of the project.

I double checked site URL, and user account I'm using:

  • is local computer admin,
  • is in farm administrators group,
  • has db_owner role on content database where I deploy,
  • has sysadmin fixed role on mssql server

I can access site and web application where I try to deploy using browser, however I can't add this site (and any other site) using SharePoint Connections in Server Explorer - it says: The site is not available.

Trying to use powershell cmdlets like Get-SPSite or Get-SPWeb on sites where I'm deploying also finishes with error that site cannot be found.

Cleaning solution, restarting VS, restarting VM doesn't help. Have you ever encountered similar issue and managed to solve it?

share|improve this question
add comment

2 Answers

Please attempt the following:

You need change the Site URL from properties tab of your project.

Click to select the project, then press F4 , the properties window will appear, and then change the site URL.

share|improve this answer
    
tried this already changing to existing and non-existing sites and that doesn't help. –  jjczopek Jul 7 '12 at 8:05
add comment

Problem solved - there were two assemblies on which custom claim provider was dependant and SecurityTokenService was throwing critical exceptions. After putting these two assemblies in GAC using Gacutil, everything was started up.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.