Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am using SharePoint Server 2007 x64 and Windows Server 2008 x64. I have setup a site with template publishing portal. I have grant anonymous access to all the site.

I want to change site logo image, I am using the following method, but has no effect. Any ideas what is wrong? If my steps are wrong, could anyone let me know what is the correct step to change site logo?

My steps are, in Site Settings --> Modify All Site Settings --> Title, description, and icon, I changed the URL in "Logo URL and Description". But has no effect.

share|improve this question
    
I am using a publishing site and faced this same issue. Instead of new logo image it was showing a red cross. Yes..the image was in Draft version and I had to check out and made it Approved then only annonymous users are able to see that now. Thanks Kusek!! –  user8173 May 3 '12 at 13:39

6 Answers 6

Since this doesn't have a selected answer yet, I'll pitch in my own. On my sharepoint site, my logo was showing up fine, but on a lot of subpages, the logo would flash up temporarily then be replaced with the default sharepoint logo.

All I had to do was open up that page's code in sharepoint designer, search for the SP default logo (wpicon.gif), and delete the associate webpart code. After doing so, your own logo should show up on the page.

My only assumption here is that the code is replacing your logo with the specified image, sort of as an "override". I have no idea why pages come with this by default, though.

share|improve this answer

I believe you are using the publishing template. Here you cannot change the title by modifying the (Title,description, Navigation) section. Instead the logo here is rendered by the CSS. Look at the masterpage, for the site and and look at the ms-globalTitlearea ID for CSS and look at the background image. This is the background image that your site is using. You can modify this image and your site will be updated.

share|improve this answer

Make sure that the Image in the Library is approved.Images that are in pending approval or Draft will not be visible to te anonymous users.

share|improve this answer
1  
in that case the anonymous users would be seeing a red cross, right? Which is not the case here. –  Jaap Vossers Nov 6 '09 at 19:29
    
Hi Kusek, the steps for me to add a logo is, I put a logo image under some directory which iis could access (i.e. somewhere under _layout directory), then get the URL of the logo image, and then set the URL in "Site Settings --> Modify All Site Settings --> Title, description, and icon". I am not sure what is your mentioned logo approval process? Anything wrong with my steps? –  George2 Nov 8 '09 at 9:06
    
Japp, you are correct to describe my scenarios. Thanks! Appreciate if you could share more insights about how to solve this issue and what is the real root cause that anonymous user can not see the change? –  George2 Nov 8 '09 at 9:07
    
@George: As you have put the image in the _layouts folder, It does not need Approval. To make sure that the URL is right. Copy the URL. Lets assume that the site is http://x then the x/_layouts/x.jpg paste this url in the IE and check if you are getting the Image. and also make sure that you have not included any sub site name for which you dont have permission is not included in the URL, that could be one issue as well. –  Kusek Nov 8 '09 at 15:38

Are you using AAM (Alternate Access Mapping)? That might be causing an issue with resolving a relative URL, especially if your farm isn't up to SP2. There are known bugs with AAM not rendering correctly in a number of places. Worst case, you may want to try "http://server_name:port_number/" to see if that works right.

Also, you might place your logo in a Picture Library at the top of the Site Collection for All Authenticated Users as Viewers then reference that as opposed to the 12-Hive.

Hope that helps.

share|improve this answer
1  
the new url is not being rendered in the output for anonymous users so I think it has nothing to do with where the new image is being stored –  Jaap Vossers Nov 6 '09 at 19:27
    
1. "Are you using AAM (Alternate Access Mapping)?" -- I am not changing any settings in AAM. 2. "12-Hive" means? –  George2 Nov 8 '09 at 9:08
    
Jaap, do I have to store the logo in picture library or I can put it in anywhere under IIS virtual directory -- e.g. somewhere under _layout? Currently I do not upload new logo into picture library, but put it under somewhere under _layout directory. –  George2 Nov 8 '09 at 9:09
    
Sorry, 12-Hive is the Core SharePoint directory on your server(s): "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\..." –  Craig Pilkenton Nov 9 '09 at 15:20
    
should be fine George, as long as you can access it using a browser it's ok –  Jaap Vossers Nov 10 '09 at 16:20

What do anonymous users see? The old image? Or no image at all? Red cross?

Look at the html rendered by the page (view source) for anonymous users. Did it render the url to the new image?

Also, if you have a custom master page, you might have a hardcoded url to the image, in which case you can change the image a million times through the site settings, but it won't make a difference :)

share|improve this answer
1  
Have you configured page output caching by any chance? –  Jaap Vossers Nov 6 '09 at 10:41
1  
Also ensure your browser didn't cache the original page (use Ctrl+F5 to force a refresh). Try to connect to the site from a different machine, different browser, etc. –  Jaap Vossers Nov 6 '09 at 10:46
1  
Navigate to master page gallery and download a copy of the master page used, or use SharePoint designer to connect to your site and open it from there. Analyse the contents of the master page. If you see a hardcoded url pointing to your old image, then that's the problem. If not, then we have to look further. –  Jaap Vossers Nov 6 '09 at 10:46
1  
When you change the Title of the site (using the same screen you used to change the url to the image) does it update the title for anonymous users? If so, I guess we can conclude that there is no caching issue. with regards to master page, check blueband.master, but I suspect you are just using an out of the box master page. –  Jaap Vossers Nov 6 '09 at 11:09
1  
an "out of the box" master page = a master page that comes with SharePoint. In other words any master page that is not produced or customised by you :) –  Jaap Vossers Nov 6 '09 at 11:29

I presume you mean that even the site administrator sees no change to the logo?

Make sure that the path to the new logo is correct. It can be absolute or relative to the existing site e.g. "/_layouts/images/titlegraphic.gif". If relative, don't forget the leading / (forward slash)

Then, use the "Click here to test" link to verify that you can browse to the image.

If the site admin sees the new logo on the site, but anonymous users do not, it would indicate permission issues.

share|improve this answer
    
"I presume you mean that even the site administrator sees no change to the logo?" -- no, when I login using administrator, and then go to Site Settings --> Modify All Site Settings, the logo could be displayed correctly. But for anonymous user and for administrator when browse non-administrative task pages, the logo can not be displayed correctly. Any ideas what is wrong? –  George2 Nov 6 '09 at 8:23
    
"use the "Click here to test" link to verify that you can browse to the image" -- the image could be displayed correctly in a new windows. I am using relative URL like, /_layouts/images/newlogo.bmp, I am not sure whether I need to change another format other than bmp? –  George2 Nov 6 '09 at 8:24
    
Here is a screen snapshot, i34.tinypic.com/23ts20y.png You can see from anonymous user perspective, the logo remains the same as the default one (the default logo of publishing template), but when I login using administrator to go to Site Settings --> Modify All Site Settings, the new logo is displayed correctly. Any ideas what is wrong? –  George2 Nov 6 '09 at 8:29
    
"If the site admin sees the new logo on the site, but anonymous users do not, it would indicate permission issues." -- Here is the steps I made, I copied the image file to layout folder related to SharePoint web site, then change the Url for the logo in "Logo URL and Description" of Site Settings --> Modify All Site Settings --> Title, description, and icon. Any ideas what is wrong? –  George2 Nov 6 '09 at 8:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.