Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am facing problem in giving a visitor user permission as "Contribute" on a particular folder inside a document library. In my scenario the user is added in the top site collection inside the visitor group to have read access to all the sub sites, but for one sub site's document library I have a sub folder on which I want to give the user contribute access. I went to that particular library and then that folder selected manage permission and then given the user permission as contribute (by breaking inheritance of permission). Now when I login with the users credential on the document library folder I cannot see the "Add New Item" link, whereas I can edit and delete the previously added files. Can anyone help me in this? What step am I missing?

share|improve this question
    
Are you on sharepoint 2010 or 2007 ? –  Arko D Jul 5 '12 at 14:34
    
Hi Moss Farmer, I as asking in 2010 context. –  Deepak Semwal Jul 5 '12 at 14:39
    
Is this add new item link disabled in the ribbon as well.. –  Arko D Jul 5 '12 at 14:48
    
Not even getting the ribbon for that user. –  Deepak Semwal Jul 5 '12 at 15:39
1  
If you are absolutely sure that you have given contribute permission level to the user at the exact folder , then go to the top site collection settings and go to the edit permission level page for contribute and see it the Edit Items and Add Items rights are checked. Alternatively, give the user Design level access temporarily on the folder and see if you are getting the add item option or not. –  Arko D Jul 5 '12 at 19:35

3 Answers 3

Give the user higher permissions. Try "DESIGN" or higher. Since you are breaking inheritance, this user will only have access to this particular library.

If you don't feel comfortable granting higher permissions. The users should still be able to add new documents by navigating to the ribbon and trying to add a document from there.

share|improve this answer

Since you are using Sharepoint 2010, navigate to teh library, open library permissions and click "Check permissions" for that user. That should confirm they have contribute access.

If they still cannot add a document, check the contribute permission level has not been customised (eg removed the Add level).

share|improve this answer

Just stop inheriting permissions for that particular folder. This will enable the option to grant privileges. There you can add more users and assign them permissions.

I tested this in SharePoint 2013. I hope the same thing works if you are using SharePoint 2010. I hope it helps.

share|improve this answer
3  
The OP has already done that, it is written in the question.. –  Robert Lindgren Jul 10 '13 at 8:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.