Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm using powershell to add metadata to my termstore. When i go to the central administration, in metadata service I can see that i have one termstore. But when i try to access it through :

$session = new-object Microsoft.SharePoint.Taxonomy.TaxonomySession($site) $termstore = $session.TermStores[$TermStoreData.termstore.name]

I don't find anything, and if I take a look at the $session object I see everything empty except the "OfflineTermstoreNames",

Do you have any ideas how I could access to the metadata termstore ?

share|improve this question
    
I have the same problem. Term store exists. I'm administrator, on the service, group, and set and yet powershell says there are no term stores. DefaultKeywordsTermStore DefaultSiteCollectionTermStor OfflineTermStoreNames TermStores e ------------------------ ----------------------------- --------------------- ---------- {Managed Metadata Service} {} –  Daniel Byrne Dec 19 '12 at 23:23
    
I have the same Problem. So when you say TurnOff the server do you really mean by server or MMS Service? Please help –  user15403 Mar 7 '13 at 16:11
add comment

5 Answers

Using:

$session = Get-SPTaxonomySession -Site $site

$termStore = $session.TermStores[$TermStoreData.termstore.name]

Does it works?

share|improve this answer
    
No, still the same proble, I have one item in OfflineTermstoreNames, and nothing in termstore :s –  Thoma Bigueres Jul 5 '12 at 14:26
add comment

Have you tried checking what termstores are available in $session.TermStores (by iterating on it)?

Are you having multiple Managed Metadata Services?

share|improve this answer
    
Yes, i've tried that, but there is no termstore "online" at all. When I look directly in my $session variable. I can only see one OfflineTermstoreName, all the other element are empty :s –  Thoma Bigueres Jul 9 '12 at 6:24
add comment
up vote 0 down vote accepted

I've found what I was looking for :

Being Administrator on the group, on the termset, on the termstore and on the service.

Turn off the server and turn it on.

It was ok for me

share|improve this answer
add comment

Maybe some of your MetaData Service Instances are disabled. See:http://blogbaris.blogspot.ch/2013/04/offline-metadata-instances-in.html

share|improve this answer
add comment

I tried all of the above with no success, but managed to bring my MM term store back online with a stop and start of ALL running instances of the Managed Metadata Web Service from the Services on Server page

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.