Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I did a SharePoint workflow according to this article: http://www.informationworker.co.za/blogs/mirror/Lists/Posts/Post.aspx?ID=873 and it does everything except send the email. How can I get this or any workflow to send an email to Task:Created By or Task: Assigned To?

share|improve this question
add comment

3 Answers

I've been having a similar issue. Emails never get received by the recipient but the workflow fires and finishes correctly (no errors). Exchange logs show the message reaching exchange but with a blank recipient. All email settings are configured correctly and SP was resolving email addresses properly (tested this).

The issue seems to be that in the body of the email I have links in HTML (A HREF etc) Once I removed the A HREF bits the emails went through. The exchange admin hasn't figured out why this is happening and it's a major issue because the users have to copy and paste the URL instead of just being able to click on it and go to their task/tickets.

No other HTML tags or code caused the emails to stop (like BR or B or FONT). Maybe it has something to do with IMF and links? I still have not fixed the issue but am working on it. Might help someone else.

share|improve this answer
add comment

I guess your outgoing email settings are not configured properly. Check Configure outgoing e-mail settings guide for more details.

share|improve this answer
    
From my research, I have discovered that SP does not resolve to email addresses properly. My email settings are fine because I can statically send an email through the workflow with no problems but not dynamically. –  user1094 Jul 19 '10 at 18:46
    
Hi lisa, SharePoint should resolve the email addresses. How are the users added to the SharePoint site? are they part of an active directory group or have they been given permissions directly on the SP site? In SP designer you should be able to use the send email action and select the user you want to email. –  Anonymous Jul 23 '10 at 11:59
add comment

I just had this issue with SP 2010 after an upgrade to 2007 and got it working. It turns out that workflows created with SP Designer do not use the "from address" and "reply-to address" specified in central admin for mail settings. It only uses the "from address", which explains why other emails were working (alerts etc). http://YourSite/_admin/globalemailconfig.aspx

Exchange IMF filters these out. We had to add an exception to exchange for the server that sends these workflow emails (our central admin server) and that resolved it.

We did not have this problem in 2007 because we were using a different mail server (a dumb relay for the most part).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.