Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I want to use AjaxControlToolkit on my application pages. I created new project where I added AjaxControlToolkit as safe control. When I deploy this project (package), I can see AjaxControlToolkit in GAC throgh C:\Windows\Assembly.

In other project, where actual application pages are, I added assembly reference for AjaxControlToolkit.dll.

But when I deploy my application pages package and try to access it, I'm getting every time: At the beginig of my application page, I added:

<%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="act" %>

But I'm getting all the time:

System.IO.FileNotFoundException: Could not load file or assembly 'AjaxControlToolkit' or one of its dependencies. The system cannot find the file specified.

So I tried by adding adding AjaxControlToolkit as safe control to my application pages package, but that doesn't help.

AjaxControlToolkit is in the GAC, but is invisible.. I'm clueless. Any advice?

share|improve this question
    
similar problem? stackoverflow.com/questions/3922167/… –  Vedran Rasol Jul 4 '12 at 17:43
1  
AjaxControlToolkit is in the GAC, but is invisible.. ? how do you know if a invisible thing is in gac :/ and did yu tried iisreset after putting it in gac –  Muhammad Raja Jul 4 '12 at 19:50
    
I meant it's invisible for my assembly since it says file can't be found when I can see it's correctly installed in GAC when I open C:\Windows\assembly –  jjczopek Jul 5 '12 at 7:30
    
Did you register it in the SafeControl section –  Sujath kumar Oct 30 '12 at 12:30
add comment

3 Answers

In line:

<%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="act" %>

put more information about assembly sth like this:

<%@ Register Assembly="AjaxControlToolkit, Version=x.x.x.x, Culture=neutral, PublicKeyToken=xxxxxxxxx" Namespace="AjaxControlToolkit" TagPrefix="act" %>

Version and public key token you can get from GAC. Just select AjaxControlToolkit assembly and click properties.

share|improve this answer
add comment

This can be due to some problems, i know it might sound mad but are you sure your using the right ajaxcontrolToolkit?

A stable one I use every day is: version 1.0.20229.20821

You can find this by going into the GAC and right clicking on ajaxcontrolToolkit and select properties.

You need to have it in the refrences in project:

"Solution Explorer" then right click "refrences" and select "Add Reference", go to the file that you downloaded making sure its the correct version.

Add the using statment at the top of the class like so: using AjaxControlToolkit;

do your code......

Add the Dll to Gac.

Add it as a safe control in manifest.xml

deploy your app and it should work smoothly ;)

Hope this helps!

share|improve this answer
add comment

Put it in the Web Application bin folder as well, sometimes it solves the problem or you might have to register it as a safe control in web.config, which should happen automatically i guess.

share|improve this answer
    
It doesnt get automatically put into safe controls .. using WSPBuilder does it for you automatically otherwise you have to do it yourself! –  ali Sharepoint Aug 23 '12 at 13:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.