Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

This our current situation

1 main-site foo.org and 2 subsites foo.org/FR and foo.org/EN (French and English) When you'll browse to foo.org, you're redirected directly to foo.org/FR/default.aspx And this is the moment where we're facing the following problem:

  • SharePoint keeps asking for credentials for the administrator. (while using http://foo.org)
  • When I add www it just logs me in as an Administrator. (http://www.foo.org)

-> This may be caused by the domain controller (which is outsourced here at work, and they're not willing to change permissions/settings)

-> adding the website to the trusted websites isn't a solution either

-> changing logon activities to a custom level also didn't work.

When I navigate to 'http://foo.org/FR/shared pages/foopage.aspx', SP asks for credentials. When I navigate to 'http://www.foo.org/FR/shared pages/foopage.aspx', SP just logs me in as an administrator, which is bad of course.

If I navigate towards to the http://foo.org/EN it redirects me to the /EN/default.aspx without asking for credentials, AND not logged in as an administrator (just as a visitor).

The problem is situated in the /FR subsite I think. When I check the masterpages of /EN and /FR, the only difference is at the point where you're able to set up the visibility of 'view all site content': (see PermissionString)

FR/master.page
<Sharepoint:SPSecurityTrimmedControl runat="server" PermissionsString="ViewPageForms">
<div class="ms-quicklaunchheader"><SharePoint:SPLinkButton id="idNavLinkViewAll" runat="server" NavigateUrl="~site/_layouts/viewlsts.aspx" Text="<%$Resources:wss,quiklnch_allcontent%>" AccessKey="<%$Resources:wss,quiklnch_allcontent_AK%>"/></div>
</SharePoint:SPSecurityTrimmedControl>



EN/master.page
<Sharepoint:SPSecurityTrimmedControl runat="server" PermissionsString="ManageLists">
<div class="ms-quicklaunchheader"><SharePoint:SPLinkButton id="idNavLinkViewAll" runat="server" NavigateUrl="~site/_layouts/viewlsts.aspx"Text="%$Resources:wss,quiklnch_allcontent%>" AccessKey="%$Resources:wss,quiklnch_allcontent_AK%>"/></div>
</SharePoint:SPSecurityTrimmedControl>

When using Fiddler, it says it needs authentication at the point where the /FR/Default.aspx is loaded. The only difference between the /EN/Default.aspx and /FR/Default.aspx is:

FR/Default.aspx
<META NAME=”ROBOTS” CONTENT=”NOHTMLINDEX”/>
<link rel=”stylesheet” type=”text/css” href=”/FR/_styles/core.css”/>

EN/Default.aspx
<link rel=”stylesheet” type=”text/css” href=”/_layouts/1036/styles/core.css?rev=qaEkY9lls4D7o5XsuDYM1g%3D%3D”/>
share|improve this question
    
Can you share the managed paths settings as well ? –  Arko D Jul 3 '12 at 13:18
    
Ben, without the managed path it will be rather difficult to identify the root cause. I have seen in more than a few occasions where multilingual sites behaved erratically when the fix was applied at the managed paths level. –  Arko D Jul 6 '12 at 12:44
add comment

2 Answers

up vote 0 down vote accepted

Problem(s) solved:

  • There was no anonymous access to my Calendar
  • The maintenance-settings for the Calendar-webpart weren't set wright

The only way to access this webpart maintenance page is by adding '/default.aspx?contents=1' At this page you should check the following:

  • Make sure your webpart is 'open at page' => Yes and 'Personalised' => No

Excuse me for wrong translations but I'm using SharePoint in French.

share|improve this answer
add comment

When you say that it logs you in as admin instead - are you saying you should be allowed access anonymously or authenticated but just a lower priv account?

I recently had an issue where we got challenged at root but okay if we went in direct at a lower level URL. Turned out I needed to switch anonymous access at the site collection AND web app level on then off again to get something internally synced up and make it start working.

share|improve this answer
1  
The web application level anonymous setting is done at the athentication provider setting in central admin. Manage Web Apps -> select an app, click authentication providers. Check/uncheck the anonymous access box. This makes web.config changes so be careful. The site collection level is under site settings -> site permissions -> Anonymous Access button in the ribbon, you will only see this button if you have anonymous set at web app level as described earlier. –  PlanetWilson Jul 9 '12 at 13:20
    
We have set up a revision by a SharePoint specialist, the answer will follow later on. –  BenCes Jul 10 '12 at 14:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.