SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a custom form on a content type I've created. This content type has 3 site columns which are a lookup field from 3 lists. In the form I've created the user selects a dropdown box and chooses an item for each field. This fields are required.

It all works fine on my development machine, but it breaks down when I deploy it in testing.

I save the 4 list as templates and upload them on the new server, then I create the 4 corresponding lists. It all looks fine while adding a new item (the 3 fields correctly find the corresponding lists and present me the items to choose from). After saving the item and opening up again every other field is filled but the 3 lookup fields.

No error is thrown while saving. It just skips the fields (which are required).

Any idea? Thanks

share|improve this question

You can't really say what the issue here is without a little more data. Let's try some troubleshooting steps....

  1. Verify whether the issue is with your forms or with your lists. Try provisioning the lists without the custom forms. Do they work as expected? If so, then the issue is with the forms. If not, your lists are to blame.

  2. Assuming the forms are broken, how are you provisioning these forms? Can you isolate which forms are broken and which ones are functional?

You're doing two pretty tricky things in a SharePoint solution - deploying lookup columns and provisioning custom forms. It would be helpful to know more about your deployment approach.

share|improve this answer
Thanks to you I found the problem. – Maurizio Pozzobon Jul 3 '12 at 10:33
I am happy to help. You can benefit others with this issue by marking the question as answered :) – Derek Gusoff Jul 3 '12 at 13:49

Found out that the were 2 problem cooperating against me with this issue.

  1. First the list was not getting created properly (I call this a bug in sharepoint), the lookup columns did not work properly. If I tried to add them to the Item cotent type with the default form they did not properly get populated. I had to remove this columns, create them again on the new server and add them back to the content type. Not a great solution, but a working workaround.
  2. The second problem was that 2 of the lookup fields (don't know why) ended up with and added '0' to their names, so they did not work after doing the steps on point 1, but worked on development. Fixing the name issues fixed the 2 lookup fields
share|improve this answer
Having similar problems - the content of lookup fields are lost upon deployment to another site/machine. From your answer I understood that you recreated lookup fields, correct? But have you managed to deploy to another machine/site without loosing content of lookup fields (I am having thousands items)? – Gennady Vanin Геннадий Ванин Aug 14 '12 at 15:38
saving the list from which I do the lookup as a template with content (there's a checkbox for that), I did not lose the content of the lookup fields and once I recreated them they worked properly – Maurizio Pozzobon Aug 30 '12 at 9:13

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.