Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have Windows server 2008 r2 box with wss 3.0 installed. I recently activated incoming email. First i installed SMTP Service in my server. After that i went to central admin-->operations-->Topology and Services-->Incoming Email Settings. There i enabled sites in this server to receive email.

Settings Mode-->Automatic

Directory Management Service -->NO

Incoming Email Server Displaying Address--> mylist@defaultsmtpserver address

Safe Email Server-->Accept mail from all email servers.

After that i went to shared documents in my web app-->settings-->incoming email settings

Assigned email id to list.

Upon doing this i can post entry to shared documents using my office outlook in same domain.

But when i try to send the email using my hotmail account nothing happens. I dont even get any errors or undelivered error message from my email client.

If anyone have any further ideas about this issue please help!!!.

Thank You

share|improve this question
    
If using WSS3.0, then why have you tagged your question to SharePoint foundation? –  Falak Mahmood Jun 29 '12 at 19:52
    
just updated the tags to you question –  Falak Mahmood Jun 29 '12 at 20:03
add comment

2 Answers 2

I finally found a fix to this problem.

Here is the link i followed: Send Email From the internet to Sharepoint

Hope it helps Thank You

share|improve this answer
add comment

SMTP server that accept mail from the Internet must allow anonymous access.

See example http://www.oceanapproach.com.au/blog/Lists/Posts/Post.aspx?ID=44

Edit:

If you can receive email in the document library, please make sure these settings have been done:

CA > Operations > Incoming email settings > Accept messages from authenticated users only: No;

Accept mail from all email servers: Checked

Document library > Settings > Incoming email settings > Accept email messages from any sender: Checked

If not, it is because you have not configured incoming email properly. Please refer to this article to configure incoming email for your SharePoint server.

share|improve this answer
    
Falak, thank you for your reply. where in IIS 7 do we apply that change i have smtp server listed when i click web server name but i dont have option to allow anonymous access. BUt i have applied your suggestion to IIS6 i did set the authentication to anonymous access and relay to All Except List below. But still no change. –  octopus Jun 29 '12 at 20:23
    
did you define Incoming e-mail settings? –  Falak Mahmood Jun 29 '12 at 20:46
    
Yes i did it is abc@example.com( it works when i set domain name to local smtp server name but not when i set it to my office email domain) –  octopus Jun 29 '12 at 20:48
    
have you configured SMTP with IIS 7? SMTP Server name must match the fully qualified domain name in the MX entry for the mail server in DNS Manager on the domain server. technet.microsoft.com/en-us/library/cc262775(v=office.12).aspx –  Falak Mahmood Jun 29 '12 at 21:01
    
I installed SMTP and when i click webserver name in iis7. I can see SMTP server. There i have store email to pickup directory checked with C:\inetpub\mainroot\drop. I havent made changes with any other fields. –  octopus Jun 29 '12 at 21:04
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.