SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yesterday, I was able to run some script upload and update MMS type columns via script.

Today, the same script unable to get hold of the taxonomy store. I can see the whole tree from any site collection (site setting > term store mgmt). Why then following ps not working? REALLY FRUSTRATED WITH SHAREPOINT LACK OF DOCUMENTATION.

$site = "http://portal.company.com/legal"
$session = get-sptaxonomysession -site $site

if ($session.TermStores.Count > 0)
{
    $ts = $session.TermStores[0]
}
else
{
    Write-Host "Term Stores not found"
}
share|improve this question
    
Looks like same issue as this guy but where is the FIX. social.technet.microsoft.com/Forums/en-US/… – M. Todd Jun 28 '12 at 19:40
    
Tried this guy's solution but no luck. sharepointlearningcurve.blogspot.com/2010/04/… – M. Todd Jun 28 '12 at 19:46
    
Adding more spicy. When running the script from the app server it worked. – M. Todd Jun 28 '12 at 20:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.