Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

In a list, I have a column for users. When I click on the username it opens up the user profile panel with information gotten from AD for that user. This is good.

You would think that if I clicked on "Edit Item" of a user's profile that I would get that user's profile, and be able to edit it. Actually, when I pull up the "Edit Personal Settings" panel (by clicking on "Edit Item" in "User Information" accessible through the welcome dropdown button), the little panel flashes almost like it was going to show me another tab, then that extra tab disappears.

Now, I don't want to use mysites at all (my users don't need special profiles). I want everything to work through AD only, and use that "Edit Item" panel - like it did in Sharepoint Services 2007.

What am I missing, and how do I get it to work the right way?

[about two weeks later...] I am still stuck here. Anybody have a clue for me? Aside from the UPS thing, the question to answer is how to get the "Edit Item" panel to display items for editing!

share|improve this question
    
hmmm, most likely problem with custom code which is been deployed as event receiver for that specific list for "Updating List Item", if you got any custom List event defined for this specific list ? –  Muhammad Raja Jun 28 '12 at 14:27
    
For this list I have no custom code at all. In fact, I just created the list by "Create site based on external data" - ie, an excel table. –  BGM Jun 28 '12 at 14:31
    
very strange, is there any chance you can create another test account in AD and test same scenario with that account and see if it does the same thing, if it does then it probably be a bug in code, that only let yu edit your profile even if you want to edit someone's else. correct me am wrong please :) –  Muhammad Raja Jun 28 '12 at 14:36
    
Okay, with another admin user (only they could get edit rights you know), it opens the right user when I click "Edit Item". However, the only thing I can edit in that panel is "Delete User from Collection" - I can't even see the other account settings for that user except the username. I am using an admin account with full rights. But in the "View Item", I can see everything. –  BGM Jun 28 '12 at 15:25
    
Well, I am looking now in SCA, and I see that whenever I click on any of the links under "Manage Profile Service/Sharepoint User Profile Service Applicaion", such as "Synchronization", "Organizations" or "People" I get an error page. –  BGM Jun 28 '12 at 15:50
show 3 more comments

2 Answers 2

  1. Login to SP using that user profile in question.
  2. Change something in the site.
  3. Log out.

Can you edit the profile information for that user now?

share|improve this answer
    
No. However, ALL the profiles are in question here. I, even as admin, only see their profile properties in the "view", and don't see any of them in "edit" mode. And none of them ever get updated. I have a related thread here:sharepoint.stackexchange.com/questions/40392/… –  BGM Jul 19 '12 at 22:23
    
Try the above steps. Pick a user (user X). On the top right corner. Log as user X. Edit something. Log back in with your credentials. Can you update the user X UP information. –  Hossein Aarabi Jul 19 '12 at 22:27
    
When you manage user permissions using AD groups, individual user profiles are not expanded until that individual user makes a change in SP. You can verify this by using the steps above. If you still cannot edit the user profile information then you have some other issues. –  Hossein Aarabi Jul 19 '12 at 22:41
    
I said, "no", I can't edit the profile information. I logged in as testuser, added something to a list, logged out. Then I logged in as me and clicked on his name in a list where users are listed and none of his specs from AD show in the profile report, even though I know they are really there. When I go from the profile report to "Edit Profile", the only thing that shows is the account login name. In AD, that account has had details for a long time. I even tried adding new ones. I also made sure the fields are linked in SCA. –  BGM Jul 19 '12 at 22:49
    
Sorry I didn't see the "no" :) I am guessing then the UPS application is not pulling all the AD information. Someone with UPS application expertise can answer that. –  Hossein Aarabi Jul 19 '12 at 23:10
show 2 more comments
up vote 0 down vote accepted

If your UPS is set up correctly, and mysites is set up correctly, when the user clicks on their username anywhere (say, in a username column), it will take them directly to that person's profile page on mysites.

With that said, the only time you will get the profile to load NOT in mysites is if the user has not yet been synchronized from AD to Sharepoint (this timing depends on the service settings in SCA).

A user may also get the NOT-mysites-profile page by clicking on their name in the welcome button (top right-hand corner) and choosing "My Settings" from that menu.

Whether a person can edit a profile in mysites depends on their level of permissions on mysites.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.