Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I'm, quite unsuccessfully until now, trying to change sharepoint's default forms. Well I can create/change and set another form to be the default and that's where my success ends.

When editing a site with designer, I try to make a new edit form and all seems to go well up to the point where sharepoint practically ignores the from. Aside from the fact that in the "new" from I see thrown in all the columns of the content type's group I chose, when I edit that no changes appear. Worst even, in the preview it seems nothing that appeared in the editable section of sharepoint designer appears. When I click edit on some content I get the "original" edit form where all the columns in the group of the content type's columns appear.

My intial intention was to hide some of the fields as the form was way too populated(no can't just remove those fields or set them to "hidden" as it appears if I do they never show up in any form or list from that point on).

Is there any way for me to edit the default edit from(yea cause I still want the dropdown list with the content type selction the default list has)?

Thank you very much.

share|improve this question
    
How is your list created? Are you defining a custom content type with custom fields? –  Steve B Jun 28 '12 at 11:41
    
yea, I'm using custom content types with custom columns, a couple of them are custom field types. –  iris Jun 28 '12 at 11:53
    
You can setup some attributes on the fields (either on the field itselft or in the list schema): ShowInDisplayForm, ShowInEditForm, and so on. Doesn't this attributes answer your problem ? –  Steve B Jun 28 '12 at 11:55
    
Unfortunately it doesn't. I have set the attributes ShowInEditForm and ShowInNewForm and they both function as "excpected". I have a custom ribbon button for the new documents and after the upload form, instead of opening NewForm it goes to the edit one. Now, since I want to be able to edit the item/document attributes I can't just set ShowInEditForm to false. –  iris Jun 28 '12 at 12:27

1 Answer 1

Assuming your version of SPD is 2010, you would need simply to open the appropiate site and then in the Navigation pane, click Lists and Libraries, select the list you want to create a form for, and then on the List Settings tab, click List Form.

The reason why the default web part you see is "locked" is also because best-practice states that you should not change that. Instead, add a new DataView Web Part and customize it. Do not delete it either, just Hide it (select it and in the Properties panel mark it as Not visible). - Deleting it could cause you loose the list for good!!!

Again, i presume you reached this far, then all you have to do make sure you Check where it says "Make this as default" which depending of whether the form declared is for View/Edit/New it would automatically be considered next time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.