Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I am trying to change the Social comment webpart -WebPartPropertyDisplayItems property to display more than 10 items in the comments section.

But its still takes only 10.is ter anyother way to update this value.

Thanks,

Sudan

share|improve this question
add comment

2 Answers 2

I haven't tried it myself but you can Go to Web Parts under Site Settings:

Download the Social Comment WebPart file (.webpart) and open it with any XML Editor. Change the WebPartPropertyDisplayItems to the number you want.

<?xml version="1.0" encoding="utf-8"?>
<webParts>
  <webPart xmlns="http://schemas.microsoft.com/WebPart/v3">
    <metaData>
      ....
      <properties>
          <property name="WebPartPropertyDisplayItems" type="int">15</property>
      </properties>
    </data>
  </webPart>
</webParts>

Save the .webpart again and upload it again to the WebPart gallery, and see the results.

Unfortunately, SocialCommentWebPart class is sealed and therefore can't be inherited.

share|improve this answer
    
I have tried updating it.but it does not work. –  Sudarsanan Jun 27 '12 at 14:41
add comment

My understanding is that this property only controls how many items are displayed with a max of 10 items. If there are more items than the property value, or if there are more than 10 items, paging will be enabled.

Update: If you want to display more than 10 comments you will need to create a custom web part that reads the social comments and displays the content in the format you desire.

share|improve this answer
    
Thanks for the reply,But is there any way we could override this 10 limit. –  Sudarsanan Jun 27 '12 at 14:35
    
As Mike suggested, try adding 10 or more comments and see if paging get enabled on Web part? –  Falak Mahmood Jun 27 '12 at 14:53
    
Yes, the paging gets enabled, But i wanted to disable the paging and display all the comments in the same page. –  Sudarsanan Jun 27 '12 at 14:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.