Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Three of the six workflows that are on one of my site collections in SharePoint 2010 are resulting in "Failed on Start" as soon as a document is submitted to a document library. The other three workflows work perfectly fine. So far, I have been unable to resolve the issue, and I see nothing in the ULS logs, nor the Windows event logs.


  • All site collections are under the same web application (claims-enabled, HTTPS).
  • Only one site collection has this problem - all other site collections work fine.
  • All of the workflows are "out of the box" and are native to SharePoint.
  • Each workflow is applied to it's own document library: "My Docs (Approval)", "My Docs (Feedback)", "My Docs (Three-State)", etc to ensure that none of the workflows interfere with each other.
  • No SharePoint Designer workflows have been created.


  • At first, I followed this enter link, which said to turn on Content Approval at the site collection level, if that option was being used in the workflow. I did, removed my test list and test workflow, but the problem still occurred on lists/workflows created after this.
  • I created a 1-step workflow in SharePoint Designer 2010 ("Start Approval process on Current Item with Admin@SharePoint.com")...it WORKED.
  • I created a new subsite within this site collection to see if the SharePoint (not Designer) workflows would work correctly, and they did not. This is what each Workflow shows in my document libraries (I have a separate document library for each Workflow type).
  • I created a brand new site collection, used Backup-SPSite and Restore-SPSite to move all content into the new site collection, in the hopes that perhaps it was just "something" wrong at the old site collection...this did nothing, of course, other than provide me another area to test in.

Workflow Results:

  1. Disposition Workflow: Completed.
  2. Three-State Workflow: Completed.
  3. Signatures Workflow: Failed on Start ("Workflow was canceled by System Account").
  4. Feedback Workflow: Failed on Start ("Workflow was canceled by System Account").
  5. Approval Workflow: Failed on Start ("Workflow was canceled by System Account").
  6. Publishing Approval Workflow (tested on Wiki library): Approved (Completed).

The Workflow History List does not give any relevant data as to why it's failing, either. Workflow History List

The SharePoint Designer Approval workflow that I created (which is a simple 1 step workflow, the best that I can do without reading further into it) works fine.

Does anyone have any idea on why 3 out of 6 workflows with SharePoint work fine, but the ones that need signatures, feedback, or approval (not counting the Publishing Approval workflow) do not work?

Thank you in advance for any help that you can provide.


  • 6/27/2012 2:57PM

I downloaded a tool called ULS Viewer and proceeded to use that. I must admit, I do not understand 10% of the information flowing across the screen when looking at the logs, but at least I was able to filter the word "workflow" out of the message category. This is what resulted:

RunWorkflow: Microsoft.SharePoint.SPException: User cannot be found.    
 at Microsoft.SharePoint.SPUserCollection.get_Item(String loginName)    
 at Microsoft.SharePoint.Workflow.SPWorkflowNoCodeSupport.LoadWorkflowBytesElevated(SPFile file, Int32 fileVer, Int32& userid, DateTime& lastModified)    
 at Microsoft.SharePoint.Workflow.SPWorkflowNoCodeSupport.LoadWorkflowBytesElevated(SPWeb web, Guid docLibID, Int32 fileID, Int32 fileVer, Int32& userid, DateTime& lastModified)    
 at Microsoft.SharePoint.Workflow.SPWorkflowNoCodeSupport.<>c__DisplayClass1.<LoadWorkflowBytes>b__0(SPSite elevatedSite, SPWeb elevatedWeb)    
 at Microsoft.SharePoint.Workflow.SPWorkflowNoCodeSupport.LoadWorkflowBytes(SPWeb web, Guid docLibID, Int32 fileID, Int32 fileVer, Int32& userid)    
 at Microsoft.SharePoint.Workflow.SPNoCodeXomlCompiler.LoadXomlAssembly(SPWorkflowAssociation association, SPWeb web)    
 at Microsoft.SharePoint.Workflow.SPWinOeHostServices.LoadDeclarativeAssembly(SPWorkflowAssociation association)    
 at Microsoft.SharePoint.Workflow.SPWinOeHostServices.CreateInstance(SPWorkflow workflow)    
 at Microsoft.SharePoint.Workflow.SPWinOeEngine.RunWorkflow(SPWorkflowHostService host, SPWorkflow workflow, Collection`1 events, TimeSpan timeOut)    
 at Microsoft.SharePoint.Workflow.SPWorkflowManager.RunWorkflowElev(SPWorkflow workflow, Collection`1 events, SPWorkflowRunOptionsInternal runOptions)

Another exception just below that one had the same detailed information, but the first line was different:

RunWorkflow: Microsoft.SharePoint.SPException: User cannot be found.
share|improve this question
anything in the ULS logs ? –  Steve B Jun 27 '12 at 20:16
The only thing that I could find in the logs that was remotely related to workflow has been added to the bottom of my question. Honestly, I feel very lost within the ULS logs, and it is hard to gather information. I downloaded ULS Viewer, so that helps, but it still all seems like Greek to me. The "User not found" error...could that be from the System Account? That's what the error message says on the Workflow (as far as why it was canceled)...but why wouldn't it be able to find the System Account? Would deleting it from the site collection help (allow it to re-add itself)? –  SalarianEngineer Jun 27 '12 at 22:02
Have you tried a different account? The "User cannot be found" error I feel like I have seen when I am (improperly) testing things as the farm / app pool account. –  SpartanDonut Jun 28 '12 at 2:29
That's correct - so while it doesn't seem to be the root cause of the problem I would at least make sure the account you test with is a normal account so that you don't get any false negatives. The next thing I would try is to deactivate and reactivate the workflow features. (Might only be one, can't remember off the top of my head) –  SpartanDonut Jun 28 '12 at 13:41
Feel free to join me in chat - chat.stackexchange.com/rooms/411/sharepoint –  SpartanDonut Jun 28 '12 at 15:59

1 Answer 1

Something within the following set of troubleshooting steps resolved the problem. Thanks to Tylerrr07 for helping out and giving advice. My best experience on SE to date!

Steps taken: - Deactivated and Reactivated all "Workflow" features in the site collection. - PSCONFIG. - Attempted to use accounts with less permissions rather than an admin account given "Full Control" on the Web Application by User Policy. - Test-SPContentDatabase to see if there were errors: 3 references to old MOSS 2007 features ("Fab 40" leftovers), but uncertain if this actually had an impact on the workflows, as it does not identify the feature by display name, only by ID.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.