Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I have wss 3.0 installed in windows server 2008 r2( 64 bit). I have installed ifilter60 in my server and made registry change in \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\14.0\Search\Setup\ContentIndexCommon\Filters\Extension and entered string 38 with pdf value. I can now search pdf title but not the content inside pdf.

I have already added pdf icon in images folder and made necessary change in docicon.xml, therefore i can now see pdf icon.

What am i doing wrong. Please Help, i need to get this done asap.

Thank You

share|improve this question
add comment

3 Answers

You also need to install the iFilter from Adobe in order to allow SharePoint to index the PDFs. The configuration changes you made simply tells SharePoint to index PDF, but the iFilter is actually what does the work. Start here: http://support.microsoft.com/kb/2293357

share|improve this answer
    
I installed ifilter6 do i need to uninstall ifilter6 and reinstall ifilter9? –  octopus Jun 26 '12 at 21:04
    
Also it is wss 3.0 not sharepoint 2010? –  octopus Jun 26 '12 at 21:12
add comment

If you run WSS3, the registry setting should include folder 12 not 14. Is that a typo in this post, or did you add the wrong path?

share|improve this answer
add comment
up vote 0 down vote accepted

I finally found the fix to the problem. Problem was i was running wss 3.0 in windows server 2008 r2 with ifilter6. Problem got solved after i uninstalled ifilter6 and installed ifilter9( This is the Most since you are running Windows Server 2008 r2). After that i made entry in \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\12.0\Search\Setup\ContentIndexCommon\Filters\Extension and entered string 38 with pdf value.

After that

In the registry editor go to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Setup\ContentIndexCommon\Filters\Extension.pdf. b. Modify or create the entry and replace the values with the following. Name = Default Type = (In SharePoint 2010 this is created by adding a Multi-String Value) Data = {E8978DA6-047F-4E3D-9C78-CDBE46041603}

PLease remember to replace the default value with this guid {E8978DA6-047F-4E3D-9C78-CDBE46041603}. This will ask sharepoint search service to use ifilterpdf9 instead of default search service.

After that i restarted search services and applied
Stsadm -o spsearch -action fullcrawlstart

Finally it started crawling the pdf. In some circumstances you also might need to reboot the server.

Thank You everyone for your help.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.