Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

Salvete! I am running Sharepoint Enterprise 2010 on Windows Server 2008R2. I want to enable email in my sharepoint lists. I don't have Microsoft Exchange.

We are moving from a 3rd party hosted service to our own server hosting. Not everything is moved yet, and we still rely on the old one for certain things, such as email.

I found these links pertinent, but not helpful enough.

How to configure incoming email in SharePoint Foundations without local SMTP

http://sharepointgeorge.com/2010/configuring-incoming-email-sharepoint-2010/

I have another server on my LAN onto which I have installed hMailServer - how do I use this server for my smtp server for sharepoint? I can see in Central Administration>System Settings>Configure outgoing e-mail settings that I can specify an outbound smtp server and a from and reply-to address, but I don't see any option for that smtp configuration to authenticate - that is, there isn't anywhere to specify the password.

So far I am still using the hosted service for email relay for my web applications in asp.net, but I can't figure out how to make sharepoint do it too. I appreciate y'all's help!

share|improve this question

2 Answers 2

So you setup the smtp server on one of your SharePoint servers, and then have your email service forward all emails to that smtp server.

Exchange only is useful because it integrates with AD and thus all of your SharePoint enabled groups and lists can appear in your address book.

EDIT:

Setup stmp in iis on one of your servers, the have your email relay to that server. For example, if your email that you have setup is @sharepoint.company.com, then setup your email relay so that all email sent to @sharepoint.company.com is relayed to the smtp service in IIS on your sharepoint server.

share|improve this answer
    
Yes, but I would have to buy Exchange, no? I know how to set up smtp inside of Sharepoint's SCA, but it doesn't really give me an option to authenticate a relay address through an external smtp server. So, are you saying to set up smtp in iis6 like in sharepointgeorge's guide (my link above), and that will give me incoming mail if my hosted server will give me a pointer to my server? –  BGM Jun 27 '12 at 2:41
    
Yes, see edit above. –  Steve Lineberry Jun 27 '12 at 11:07
1  
Please notice my change above - I have hMailServer configured now as a regular mail server, and need to use it as the smtp server for my domain. –  BGM Jul 2 '12 at 15:18
    
Hello again! I am back to this, and need to solve my problem! I have hMailServer configured on one of my servers, and I want to use it as SMTP for my Portal. I entered the info for my mailserver in SCA, but I can't see any way to set the password so it can authenticate. My log files tell me the email is being sent, however. –  BGM Sep 14 '12 at 16:51
1  
I would setup a subdomain so that it is @something.company.com so you can setup the appropriate mail routing rules. –  Steve Lineberry Nov 9 '12 at 16:22
up vote 1 down vote accepted

Ah! I solved it. In another thread, I actually explain my solution in depth.

The whole thing is a little confusing. The clencher, which is elusive is this: Sharepoint sends mail using the iis6 Virtual Server that interfaces some other SMTP server, which is why it is called virtual (I think).

But Sharepoint does not have anything built-in to receive mail. What you do in Sharepoint is to configure it to LOOK in folder to see if anyone has placed any eml files there. If any of the TO addresses happen to match any of its email-enabled list addresses, it will pick up those emails (removing them from the drop-folder) and "deliver" them to the email-enabled lists.

What most of the tutorials don't tell you is that your mail server (or some specialized solution) needs to place the message files in Sharepoint's drop folder. Sharepoint doesn't look past the drop folder.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.