Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

When I open a Microsoft Office Database that is on my Sharepoint 2010 portal, it does indeed, open Microsoft Access 2010, but it says, "Read Only This database was connected to a Microsoft Access Services site that is not compatible with this version of Microsoft Access. You cannot make design changes or modify data in this database."

It also tells me, upon saving and opening a database in Access, "The RunDataMacro action failed to invoke a data macro on the server. Please check your connectivity to the server."

Now, the server is running Sharepoint Server 2010 Enterprise, and I have Office 2010 Professional on my own Windows7 64bit computer. I am admin in both places, and using a Domain Admin account.

I have even set Access Trust Center options to "enable all macros", and "enable all activex" along with disabling safe mode. I have added the portal site to "trusted locations", and checked "allow all documents on network to be trusted."

How can it not be compatible? Have I not configured something in Sharepoint Server?

share|improve this question
    
Are you expecting this to work via Access Services? Or are you just using SharePoint as a file share for your database? –  Robert Kaucher Jun 26 '12 at 15:27
    
Well, I created an "Assets" list, which has lots of access databases (that I can see if I go to "options/settings", and I want to configure them, and it seems I must use Access to do that. So, to answer your question, I am not using my own database, but trying to gain entry to Sharepoint's access databases. –  BGM Jun 26 '12 at 15:42
    
Okay, I am able to open lists in Access, but can't do anything at all with Sharepoint Designer - it won't even start when I click on the edit in sharepoint designer link. –  BGM Jun 27 '12 at 2:25
    
Okay, I reinstalled Sharepoint Designer with the "repair" feature and it works now. Lord knows what went wrong before. –  BGM Jun 27 '12 at 15:47
add comment

2 Answers

It's just the way Access files are. Unlike other Office documents, Access DB's aren't just zipped XML files, and so the system can't handle them in the same way.

Open the document by clicking on it in the list (not selecting edit document in the ribbon). You will be given the option to save a local copy as it opens, do that. Then you will then have the option to "Save to SharePoint Site".

I'm not sure if this is just a work around, and there's a better way to accomplish it but it works.

share|improve this answer
    
Thanks for reading - but that is just what I am doing. I click on the document in the list (not in the ribbon) and then save it locally. I am asked to log in again (even though I am logged into the portal!), I get the macro warning, and then the warning about not being compatible. –  BGM Jun 26 '12 at 15:24
add comment
up vote 0 down vote accepted

Try adding your portal address to the "trusted" addresses for your intranet. Go to Internet Options>Intranet>Advanced.

This will prevent you from having to log in each time you access a document, and will help you by way of development access.

If you are having trouble with Sharepoint Designer, make sure you install the 32 bit version, and perhaps, choose "repair installation".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.