Take the 2-minute tour ×
SharePoint Stack Exchange is a question and answer site for SharePoint enthusiasts. It's 100% free, no registration required.

I had created 2 User Profiles one for Intranet and one for Extranet .Now when i am using profile search in my sites( i had created separate web applications for my sites for users depending on their domain) the results are showing user profiles form both of the domains is there a way i can limit that.

Regards Anil

share|improve this question
    
did you configure User profile service applications separately? –  Falak Mahmood Jun 25 '12 at 17:54
    
Yes Falak i had configured 2 User profile Service Applications ..For mysiteint I set User Profile Intranet as default and for mysiteext i set User Profile Extranet as Default –  Anil Jun 25 '12 at 17:58

2 Answers 2

On the same note as Per, because you already have 2 Web Applications for each of "My Sites", after configuring 2 Search SA's you would actually need to use the Service Connections under Manage Web Applications to establish the correct relationship for either the User Profile SA and Search SA (of course each Search SA is targeting apropiate Content Source or at least Shared Search Scope).

That is the intended usage of separation provided by using multiple Service Applications in SP 2010. In addition you could use PowerShell to Create custom groups and move your SAs appropiately (as here http://www.wictorwilen.se/Post/Give-your-SharePoint-2010-custom-Application-Proxy-Groups-pretty-names.aspx).

share|improve this answer
    
Thanks much Marius that solved my problem also thanks for the additional info.. –  Anil Jun 26 '12 at 19:19
    
Hi Marius Can you please go through my other question it would be really helpful if you can help me solve my other question sharepoint.stackexchange.com/questions/38979/… –  Anil Jun 26 '12 at 19:21

You have to set up two Search Service Applications one for Intranet and one for Extranet. Then you can configure each mysite to it's own search application, which should then do the sps3 crawl against the corresponding mysite

share|improve this answer
    
Thank you Per .....It solved my problem.. –  Anil Jun 26 '12 at 19:19
    
Hi Per Can you please go through my other question it would be really helpful if you can help me solve my other question sharepoint.stackexchange.com/questions/38979/… –  Anil Jun 26 '12 at 19:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.